[F] Not responding after trying to change directory

bug-fixed

#1

After right-clicking on a folder and sending it to Mp3tag, Mp3tag opens and displays files normally. I can do any process on the files I want, but if I click on the "change directory" button, Mp3tag hangs and becomes non-responsive to any other action, including close.

Using File/Change directory produces the same effect.

After a few seconds the minimize/restore/close buttons become active, but on clicking "close" the "This program is not responding" box comes up. The mouse continues to be an hourglass unless over the minimize/restore/close buttons.

Opening Mp3tag by clicking its shortcut and then using either change directory method mentioned above produces the same effect, whether there are files in the folder or not.

UPDATE: This always occurs if I open Mp3tag and never select a file at all before trying to change directories. Selecting even one file, whether I edit it or not, allows Mp3tag to work correctly.


#2

I curious why this hasn't been given a rating, seeing as how Mp3tag stops responding when it happens. Did I leave something out in my description?


#3

I have exactly the same problem, you have described it perfectly.

EDIT: Sometimes my copy hangs even if I do select a file...


#4

Does this issue also occur with the current Development Build?


#5

I have not seen this. I use Win XP. You?


#6

Yes, You're right. It seems you have to do at least 1 edit to be sure you can navigate.


#7

Yes, I'm using XP SP3 with latest updates.


#8

I just installed mp3tagv244e and gave it a quick test and did not have this problem. In fact, the directory tree came up faster than ever before.

Thanks for the suggestion.


#9

Glad to read that. Thanks for talking back!

Kind regards,
Florian


#10

The problem is back after updating mp3tagv244e to 245a. I can't get it to change directories at all, it always hangs.

Is it possible a service is not running that it needs? Or that the number of folders is too great?

I did a complete uninstall/reinstall and set my favorite directory to one that has no MP3s in it. It hangs as soon as I try to do any command that requires directory information, whether from the toolbar or menu. Opening Options and trying to browse for a new favorite also locks it up. During lockup it uses no cpu time.

I'm stumped. 244e worked, now 245a doesn't. What's different?


#11

Sorry, but I haven't changed anything regarding this functionality.


#12

Is there anything I can do to help figure out why this is happening?


#13

Latest version mp3tagv245b has same problem.


#14

2.46a still has this problem for me. I have the best chance of seeing the directory nav window if I run mp3tag before anything else right after booting. If I wait, it will just hang, even after modifying a file (the trick used to work).

Anyone else (still) have this problem?