[F] Problems saving on a network drive in Windows Vista

Hi all!

Recently I installed Vista, everything works fine (more or less, hehe), but I can't get MP3tag to change mp3-files on a network drive (the server is reached via samba on linux). Renaming files works fine, but when I want to save changes or remove tags I'm only getting a "Konnte nicht zum Schreiben geöffnet werden"-error (can't open file for writing).

Access right are ok, I tried it with a hex-editor, I can write away without any problems.

Any thoughts on this one? Btw, I tried the newest development-build, same problem...

Bye, Stephan

Hi Stephan,

I've just tried it with a standard windows share and it works without problems.

Kind regards,

You could also look at samba logs on linux side to see if it reports some error.


Just installed mp3tag 2.38 to see if the problems got better - but no chance.
Still the same problems here, can't write id3-tags to a samba-mounted network drive.

Client OS is Vista Home Premium German, with mp3tag version 2.38
Server OS is Gentoo Linux with a 2.6.19 kernel, with samba version 3.0.24

Here is the relevant stuff from the samba log, log-level 2.

[2007/05/29 23:52:26, 2] smbd/open.c:open_file(352)
  temp opened file audio/mp3/xxxxx/01 - xxxxx.mp3 read=Yes write=No (numopen=18)
[2007/05/29 23:52:26, 2] smbd/close.c:close_normal_file(344)
  temp closed file audio/mp3/xxxxx/01 - xxxxx.mp3 (numopen=17)
[2007/05/29 23:52:27, 2] smbd/open.c:open_file(352)
  temp opened file audio/mp3/xxxxx/01 - xxxxx.mp3 read=Yes write=No (numopen=18)
[2007/05/29 23:52:27, 2] smbd/close.c:close_normal_file(344)
  temp closed file audio/mp3/xxxxx/01 - xxxxx.mp3 (numopen=17)

Even on higher Log-Levels no errors can be found. What I don't understand, why does it state "write=No"? Does it mean that he CAN'T write or that he doesn't WANT to write?

I have one other application that behaves the same - the free text-editor pspad. This one can't write to my linux-shares, too. I tried it with notepad++, this one worked like a charm.

But back to mp3tag, I tried it with 2 other ID3-Tag-Editors (thegodfather and TagScanner), both worked right away. Here is an excerpt from the logfile when writing with TagScanner:

[2007/05/30 00:03:48, 2] smbd/open.c:open_file(352)
  temp opened file audio/mp3/xxxxx/01 - xxxxx.mp3 read=Yes write=Yes (numopen=14)

It says "write=Yes", beaneath about 15 other open/closes of the same file with "write=No". mp3tag only does 4 open/closes...

So maybe there was some kind of a change in Vistas network code or something? That there has to be done something different to open files from a network drive? I'm clueless :frowning:

Is there anyone with my given configuration, Vista on client and Samba on the server side?

Hope we get this solved... Don't want to change my favorite id3-tagger :wink:

Bye, Stephan

I'm on vacation from today till June 11, but I'll look at the problem again when I'm back.

Kind regards,

Hi Florian,

I'm getting the "cannot open file for writing error" on most MP3s under Vista Home Premium using a Standard User account (User Account Control turned off). If I edit the tag with an admin account, it works fine. AND, after editing with an admin account, I can then edit that tag with the Standard User account. No network share involved; this is all happening on the Vista machine.



Hi Brad, is the share you're writing to on the same machine? Or on another computer's share?

My problem isn't solved with Admin-Rights, but I haven't tried turning off UAC yet. I'll try that and report...

Bye, Stephan

Hi Stephan,

Not a share at all. Just using Mp3tag on my Vista machine, logged in as a standard user.

I have come to the conclusion that Vista is not READY yet. Too many problems; this one, much hassle with iTunes and others! Oh well! Don't recommend that anyone upgrade to Vista yet, unless they have to. :frowning:

Still no solution to the Mp3tag issue, either. :frowning:


The problem with saving to Samba shares should be fixed with the latest Development Build.

Kind regards,

I have my audio files on a 500G external Hard Drive and have been making changes to my filenames using the Convert Action feature (wonderful by the way). I have two systems using Vista.

When I perform this action over the network, I end up with some filenames changed to tmp....

When I perform this action not over the network having the external drive hooked up via ESATA, all is well.

I'm sharing this information in hopes that the developer(s) may find this information helpful.

Great Job!


PS I wish someone within Microsoft could have deleted the Vista Source code. Vista is becoming more annoying to me every day.

I am seeing the same problem where intermittently a file can't be changed over the network from a Vista machine. I have noticed it only occurs with large files it is trying to modify tags on. I always get a tmp file being placed in the directory. I am using 2.39. Any ideas?

Have you applied the latest updates for Vista, the Vista Compatibility, Performance and Reliability patches?

Have you tried this from an Administrator command window?

netsh int tcp set global autotuninglevel=disable

That command will disable Vista's auto tuning feature which can/does cause problems especially on LAN throughput.

Finally, Vista has the same 10 half open connection limit as XP SP2.
You may be getting a block on TCP/IP, have you checked system event logs?

The Vista limit is harder to work around but it can be done.

So.. I have this exact problem under XP.

I am running version 2.39 now... and Re tagging works fine on local hard drives in my XP machine.

BUT when I try to change files on my Ubuntu machine (samba, of course) I get the write error noted above, and the TMP files noted above.

I have no problems with permissions outside of mp3 tag.

can it be solved?


Got the same problem with my Vista Enterprise; but with v2.43.
Solved my problem by alternate click on icon and choosing the option "runs as administrator", works fine now.

Florian... why is this topic in the 'Fixed Bugs' forum?

I have the same problem. My mp3 files are in a NAS (D-Link DNS323, aka samba with Ext2). When I tried to modify the tags of a big mp3 file (appr. >10MB), I got an error message:

"File m:\\folder\big.mp3 cannot be opened for writing"

The result is a tmp file in the folder, almost the same size as the original file. The 'Basic info' was filled, half of the ID3v1 fields were filled, other half are empty, and the ID3v2 fields are empty as well.

I tried the 'run as admin' method, but the NAS authenticates me, so I have to use the NAS user/pw - the result was the same error.

I tried to modify this tags with Winamp - through the network - and there wasn't any problem. So I think, it is definitely not samba problem, not Vista problem, not UAC problem, not permission problem - it is the problem of the mp3tag program. (Because the Winamp works well in the very same environment, without any tricks.)

When I copied that big mp3 file into the local disk, the mp3tag changed the tags without any problem.

I set the network timeot to 9999999 in the tools menu of the mp3tag.

In the NAS I don't use the jumbo frames option.

I use the 2.45a version of the program.

It is only at the first sight a little problem. The sizes of my mp3 files mostly bigger than 10 MB. Now, when I want to make tidy in my audio library, I have to copy that 1xx GB into my local disk - and then back?

joep, I have all my music on a D-Link DNS-323 as well and I am not having any trouble at all tagging my music & most certainly not the problem you outline in your post as I never have to run mp3tag as Admin.

All I can tell you is what my configuration is and perhaps one of the things that are different will point you in the right direction.

My DNS-323 is running two Seagate 1.5TB drives, formatted EXT2, and they have their access set to read/write using credentials different than my Windows login info. I am using 9,000 K Jumbo Frames, and using the 1.08 Beta 9 firmware with LLTD turned on.

My OS is Windows 7 rather than Vista and the majority of my music comprises of FLAC files not MP3s.

Oh, and one last thing that might play a part I have mp3tag installed to my D: drive rather than C:.

Looking over my list above things for you to check are: the read/write status of your credentials on your DNS-323, DNS-323 firmware revision, whether you need LLTD turned on or off (I have heard with Vista you do), and as a last resort you may want to try installing mp3tag to a different hard drive. Windows Vista & 7 treats the C: drive and C:\Program Files differently than other hard drives and folders.

EDIT: There is a bit of weirdness with the DNS-323 where if you try to write to a folder with credentials that had been created by the default ones it can lead to error messages. Maybe that is what you are seeing?

Just to confirm the above message it is definitely a file size issue when networking to a samba shared drive on Linux, I can edit mp3 files no problem but when I go to amend a flac file (x10 bigger) it hangs and says it can't open to write however it is creating a tmp file almost equal in size to the one it is attempting to write to. Beyond my expertise to suggest a solution I'm afraid but this is the problem ! Not sure if this is an mp3tag issue or a linux/samba issue??

In the interim I can copy to laptop, amend and copy back but a bit inefficient to say the least. Great program though !

Regards, Ian

This bug is still present, although it might be a problem with samba.

Florian, you said "this problem was fixed in the latest development build". What did you change? In the light of many users still having this problem, why is this bug in the "fixed" section?

See also:

See for /t/11248/1 a summary thread regarding this problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.