[F] Sorting on %_Length% field doesn't sort correctly.

bug-fixed

#1

MP3Tag v2.40c (though may be present in earlier versions - just noticed it now).

With a range of MP3 files displayed, attempting to sort on the time length field results in incorrect sort order for entries less than/greater than one hour.

See http://members.optusnet.com.au/~jt_mobile/length_sort_screen.JPG While there are entries that go past the bottom of the screen, you still get an idea of what's going on. The length field is third from the right (Comment, Genre, then Length).

The far top entry is a little over an hour, for all other entries, they are sorted correctly. There is an entry at the very bottom (scrolled past the edge of that screen grab) that's at 57 minutes. It would make sense the hour long entry should be placed at the bottom.

I've included a right-click on the column line to show what type of "lenth" I'm using. As I understand it there are at least two: There is the actual file length (%_length% which is what I'm using), and there is a Tag field called length that's also used (I'm not using that as I see no point).


#2

You should enter %_length_seconds% at Sort by: and tick [x] Numeric


#3

I've changed this for new installations with the current Development Build v2.40d.


#4

How does one maintain an [hour:minute:second] format display as before?

I'm not going to translate seconds to a real-life time I can understand. That's what computers are for.
And having BOTH %_length% and %_length_seconds% seems a little silly to me.

Or am I missing something?


#5

No need to parse seconds :slight_smile:

Just leave %_length% as before and enter %_length_seconds% at Sort by. Also make sure that you tick the Numeric checkbox as dano suggested.


Length sorts as Text, not Numeric
#6

Ah, I missed the implication that the "Sort By" statement actually meant the "Sort By" field in the Columns setup box. Understood now, and working as desired. Thanks muchly.