[F] TAG field not showing ID3v1

bug-fixed

#1

I added the TAG & TAGREAD field as extra columns in the fileview.
I notice that TAG is not always showing ID3v1 on mp3 files, which I'm sure having a ID3v1 tags inside.

Simulate like this:

  1. In Options, ID3: I first set a button on Read: ID3v1 only (no buttons at the other ID3v2). Like this I see which files have an ID3v1 tag.
  2. Again in Options, ID3: no buttons at the Read section. So in the fileview I don't see any IDtag contents.
    The TAG field is still showing what kind of ID3 tags are inside the files. But if you look for a file that has a ID3v1 tag inside (tested in step 1°), you will notice that the TAG field doesn't indicate this.
    ID3v2 and APE are showing OK.

#2

Sorry, but I cannot reproduce this here. I have lots of MP3s with ID3v1 tags only and everything shows up fine.


#3

I just tried again, it can do it all time:
I also noticed that the field Tagsize goes from i.e. 128 to 0.

So when I have Option, Tag, Mpeg, Read, ID3v1 marked: in the list I see files with fields:
Tag | TagRead
ID3v1 | ID3v1
ID3v1 ID3v2 | ID3v1
....

When I disable all the Read options & Refresh the screen I see ('-' = empty):

Tag TagRead
ID3v2 -

The fact that TagRead shows empty is OK but Tag should still be 'ID3v1' or 'ID3v1 ID3v2' as above, the Tags are still in the files although currently not showing.

When I choose for only Option Read ID3V2 then:

Tag TagRead
ID3v2.3 IDv2.3

Again ID3v1 is gone.
I also notice as soon as I choose Option Read ID3v2 the Tag field starts showing ID3v2.3 or ID3v2.4 while in the first case (only Read IDv1) it shows IDv2 (whitout the .3 or .4 at the back)?

I don't see a reason why the field Tag and Tagsize has to be changed in the list view by the way of how the Option Tags Mpeg Read is set. The Tags are in the files or aren't, they don't change by way you like to display them, unless you start writing them different but in these simulation Write was disabled.


#4

@Sebastian, can you reproduce this now? Do you want more info?


#5

I can reproduce it and don't need additional info.

Thanks for reporting!

Best regards,
Florian


#6

Fixed.