[F] v2.20: geänderte Tags werden nicht gespeichert


#1

Dieser Fehler tritt bei mir unter Windows NT 4.0 SP6 immer wieder auf, sofern mehrere Dateien selektiert sind. Ist nur eine Datei ausgewählt, arbeitet das Programm korrekt.

Ich habe nur MP3-Dateien, kann also nicht sagen, inwieweit andere Dateiformate betroffen sind. Im Optionendialog habe ich eingestellt, dass nur ID3v1 gespeichert wird. Gelesen und entfernt wird jeweils alles (ID3v1, ID3v2 und APE).

Der Fehler tritt auch auf, wenn ich zuerst alle Tags entferne und dann mit CTRL-Z nur die ID3v1 Tags wieder schreibe.

Der Fehler stellt sich so dar:

  • Man wählt mehrere Dateien aus (z.B. mit CTRL-A) und ändert beispielsweise den Albumtitel und das Genre, und speichert dann
  • Man ändert ein anderes Feld, z.B. den Kommentar, und speichert erneut, wobei man die anderen Felder auf lässt.
  • Anschließend klickt man auf eine Datei
  • Nun sind die Änderungen aus dem ersten Speichervorgang weg. Es ist, als ob man nichts gemacht hätte. "Weg" ist dabei nicht ganz korrekt: genauer gesagt sind die ursprünglichen Daten wieder da (die ja überschrieben bzw. sogar entfernt wurden).

Insbesondere ist es mir noch nicht gelungen, mit dem Track-Nummern-Assistenten eine dauerhafte Änderung durchzuführen. Das Track-Tag ist zuerst scheinbar gesetzt, dann aber plötzlich wieder leer. Führt man sofort nach dem Track-Nummern-Assistenten die Aktion Tag-Dateiname aus, sind alle %track%-Werte auf 0 gesetzt.

Bin ziemlich ratlos - tritt das Problem nur bei mir auf?


#2

Hallo Woody,

vielen Dank für den Hinweis! Ich habe den abend über versucht den Fehler zu beheben und hoffe, dass mit dem aktuellen Development Build nun wieder alles wie gewohnt funktioniert.

Viele Grüße,
~ Florian


#3

Hallo Florian,

herzlichen Dank für die schnelle Reaktion! Ich bin erst heute wieder hier gewesen und habe mir gleich den aktuellen Developer Build 2.20g runtergeladen.

Meine gestrige Mitteilung, die Änderungen würden nun gespeichert, hat sich leider als vorschnell herausgestellt. Der Bug tritt zwar nun nicht mehr so reproduzierbar, aber doch noch auf.

Auch sieht es immer wieder so aus, als würde die die Änderungs-Status-Messagebox einzufrieren (Bug aus v2.19, der in v2.20 behoben wurde), aber nach mehreren Sekunden verschwindet die Box doch von allein. Puuh ... :stuck_out_tongue:

Vielleicht schaust du noch mal, ob in deinen Quellen evtl. mehrere Stellen einen Fix benötigen?

Grüße
vom Waldspecht


#4

Hallo Woody,

tut mir leid. Ich habe nun ungefähr 2 Stunden probiert den Fehler nochmal zu reproduzieren und hatte dabei keinen Erfolg. Auch beim erneuten Review des Quellcodes an den betroffenen Stellen sind mir keine Fehler aufgefallen.

Viele Grüße,
~ Florian


#5

Bin ich hier der einzige, der noch NT4 laufen hat? Scheint so...

Jedenfalls wollte ich nur eine wiederholt beobachtete neue Ausprägung des Bugs erwähnen: Wenn ich für mehrere gleichzeitig markierte Dateien eine Änderung speichere, Mp3tag beende und neu starte, dann sind die zuvor nicht geänderten Felder nun tatsächlich mit "" belegt! Das heisst, das wird vom Programm nicht nur angezeigt, sondern auch tatsächlich geschrieben!!! Ist ja wohl ein schlechter Witz...

Ein verzweifelter User


#6

Hast Du die Sprache von Mp3tag gewechselt (z.B. Deutsch -> Englisch)?

~ Florian