"File Cannot Be Opened For Writing"

I'm having trouble tagging a specific album. I usually use this program (because it's the best there is) but with this album I've tried other programs and none of them are able to tag them.

It's an album of .FLAC files but when I press "Save Tag" it says "This file cannot be opened for writing".

I've checked permissions and I'm the owner with Full Control - this is just boggling my mind.

Has anyone seen this before? If so can you please advise?

Maybe some more information will help...

Using Windows 7 64bit.

I don't use iTunes or anything other than Winamp. In fact these files haven't even been touched by Winamp.

I tried other .FLAC files, just as large if not larger and it had no problem...they even reside within the same directory as the problem files.

I'm absolutely at a loss.

Is it possible that the files are corrupted or not really FLAC files?
If you rip the files yourself, you can be sure of their quality and authenticity but you can't always trust the file extension for files that are acquired elsewhere.

Software is available that may help you verify the codec. Three programs are; MediaInfo, Audio Identifier, and AudioChecker.

Hi, thanks for the reply. Yes, these are in fact, .FLAC files.

I have the same problem editing newly created FLAC files. I am batch-converting my CD collection using Nero Kwik Media. MP3Tag can read/write some files perfectly fine, while others show nothing in Codec/bit rate/frequency fields and any attempt to change tags in those result in the same "File cannot be opened for writing" error. None of the files are read-only (in fact, I have a folder where half files is OK and half has problems), and all of them play perfectly fine in VLC.


Windows 7 seems to be a little more beasty concerning access and locking of files. It seems like a good idea not to have any other Explorer window open while editing larger files.
Apparently the indexer and the preview generator grab the files the minute they detect a modification.
So, if you want to edit the files either ...
copy the path from the explorer and merge it into the address inputbox in the tag panel, then close the explorer

use the built-in directory selection methods of mp3tag.

So far my theory (this is how I work and I have not yet experienced this kind of trouble).
Could you please give a feedback?

I am having the same exact issue. Anyone ever find a solution?

What about "File Cannot Be Opened For Writing"?

Are file attributes set to "Read Only"?

I encounter this issue from time to time, but it usually occurs on a single file when running through a bunch of batch actions. My situation is likely attributable to the scenario ohrenkino listed above. On my end, I consider it a non-issue chalked up to Win7's indexer and preview generator. However, I never encountered an entire directory being read only unless I specifically changed the file attributes or it somehow resides on a corrupted sector(s) of my HDD.

Better to check the file and directory attributes and/or run CHKDSK /F DriveLetter or CHKDSK /R DriveLetter. The former CHKDSK fixes corrupted files and the latter scans and locates any bad sectors. Maybe you should include /X flag to dismount the drive when checking for bad sectors.


my turn to trip over this very old chestnut with an archived folder with flac files (not read only, and the music played fine).

Tried without success:

  1. take ownership of folder, files
  2. select files from within mp3tag rather than context menu

Then used foobar to convert flac to flac and that worked, so can now adjust tags etc.

That seems to be my issue too, though my files are standard mp3, exported from premiere. The files have had tags, (and still do), but they do nt show up under the install of the app on windows 10. When I tried to recreate them in one of the files I get the 'cannot open for writing' error.
Is it just a windows 10 thing? The file is not marked 'read only' in properties.

There are so many steps described in the thread including links to other threads.
Which of the steps have you performed and what was the outcome?


I'm also having this same issue. However, it's only from a certain way of trying. Everything works fine when editing files from my PC or a NAS Hard Drive, but when using an IDE Laptop Hard Drive in a USB Enclosure, neither the File Names (in the Filename listings area) or the MP3 Tags can be edited via with MP3Tag. I get the error "File xxx cannot be opened for writing." I can access the files just fine with File Explorer (Windows 10), and edit the title names, etc., but MP3Tag can't work with them.

These are the same MP3s that are on the NAS, just copies of them on the USD Hard Drive. They are not copy protected or set to read only. So, since it doesn't seem to be a problem with the MP3Tag v2.82 program itself, I'm wondering if you have any suggestions for me. I haven't seen anyone post this kind of specific detail, but maybe this was their problem as well.

Thanks in advance,


Just to get into the right direction: MP3tag only reports that what the OS reports back.
So you have to check what happens in your OS environment.
And if the file cannot be opened for writing then another process/program blocks it (if you have ruled out all the other problems coming along with insufficient access rights).
So: what other programs (including Windows Explorer) access the files at the same time?
Close these and what happens then?

Thanks for the quick reply!

I'll look into this more closely today, but I need a little more help.

I don't know what this means.

Can Access Rights get changed in the process of copying files to a USB Hard Drive?
I'm not sure how to change them myself, if they need to be adjusted.

As far as I know, the only programs that had those particular MP3s open were MP3Tag and Windows 10's File Explorer. Like I said, I've used MP3Tag successfully with the same files on my PC and my NAS. But this is where I'll start today, working only with the USB Hard Drive, and I'll report back.

In the meantime, if you could address my comments to what you said that is highlighted in red, I'd appreciate it.

Thanks again.

I was a little confused about what to do at first, and how to do it, but I made a start. I looked at Read-only on the USB Hard Drive and found that unchecking the Read-only box doesn't make changes to sub-subfolders. As I kept going into subfolders, I found what had to be done everywhere else.

Then I looked into Permissions and found something to try. I set the permissions on the entire USB Hard Drive to Full under my User. It was already set to Full under Administrator, but the changes to Read-only and to my User Permissions seems to have fixed the problem.

This made me take a look at the NAS and I found that some of the files were set to Read-only, so I'm changing them all. Then I'll have a look at Permissions there as well. I guess this should prevent future copies from having issues.

Guess I'll have to look at the PC after that.

Thanks for working with us!

Apparently, you have found a number of issues in your OS environment in respect to ownership and read-only flags.
You remedy these issues with the OS utilities - so this did not have to do anything with MP3tag. MP3tag was only the messenger: it reported that files could not be opened for writing (for whatever reason).
As the previous posts addressed write protection and access rights (it is generally not enough to be admin on a machine, you have to be the owner or access rights have to be set in such a way that "everyone" has full rights - which you might not want) I added the possibility of temporarily blocking programs (whereas the OS stuff usually leads to a permanent block).
But all these circumstances can only be seen locally - and you checked locally, so everything is fine now, I think.

I've checked all music files everywhere for Read-only and Permissions, and tested many of the files in MP3Tag. I think all is well now.

Thanks for making me think about everything that could have been an issue!

HI All ,

I also had this issue and yes it was driving me nuts .......................

By good luck I found out the culprit in my case was image files in the wrong format

Just an FYI. In Win 10 I had the same issue with some m4b files and found that they were being synced to OneDrive (Don't remember setting that up). You can tell by the status column in Explorer.