%_file_size% doesn't work

Tried to filter using "%_file_size% GREATER 10000" and results were always zero. When I changed to %_file_size_bytes% it worked as expected.

Mike

I've got a file the size about 16 MB.
%_file_size% returns "16,79 MB"
%_file_size_bytes% returns "17609771"

So you probably need to adapt

to
%_file_size% GREATER 16
or use %_file_size_bytes%

In filtering, no files returned even if I do GREATER 0

I assume that the result is a string for %_file_size% whereas %_file_size_bytes% is a number and GREATER works for numbers only.

Do you know, or only assume? How do you know?

I assume.
You could try
%_file_size% HAS 16
and see if that leads to any hits

OK, that does work. Thanks much.

It's implemented like that at the moment. However, I think it can be improved so that it also works with "numerical strings", i.e., what's provided by %_file_size%, e.g., "16,79 MB"

I'll look into this and keep you posted!

1 Like

This is now available with Mp3tag for Mac v1.4.2.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.