Fix BPM tag?

My BPM tags are like this: "00098 BPM" (without the quotes of course)

I want to remove the leading zeros, and the trailing " BPM", I've tried every option I could find, replace with regex, format value, etc; I've copied and modiefed the regexs here, and I've even tried replacing BPM with nothing, and NOTHING will work, idk what i'm doing wrong at this point.

Action "Format value" ... or ... Convert "Tag - Tag"

BPM <== $regexp('00098 BPM','^0*(\d+).*$','$1') ==> '98'

BPM <== $trimLeft($cutRight('00098 BPM',4),'0') ==> '98'

BPM <== $trimLeft($cutRight(%BPM%,4),'0')

BPM <== $num('00098 BPM',1) ==> '98'

BPM <== $num(%BPM%,1)

DD.20140903.1614.CEST, DD.20150212.1620.CET

I tried using $trimLeft($cutRight(%BPM%,4),'0') as both replace with regex and format value, and it's not working; is my mp3tag possibly messed up?

Make sure that you have set Mp3tag to read the proper tag-type.
Load one media file into Mp3tag, from which you know for sure, that there is such a BPM string in the tag data.
Select the file and open the dialog "Extended Tags...:".
Do you see such value '00098 BPM' in the 'Metadata' list?
What is the name of the tag-field with this value?

DD.20140903.1647.CEST

The name of that tag field is just BPM

What file-type have you got?
I think that mp4 files show bpm in such a format. That's the way it is then.

Yeah, they're MP4 files, but it's still REALLY weird that it wouldn't work with a specific file format

AFAIK, mp4 also does not like leading zeros for track. So perhaps they have all gone to the BPM field. No, just kidding.