Flawed tags on USB-stick/Smartphone

I tag audio files (*.wav) with v3.08 on my PC (Windows10 Pro) and copy them to a USB stick and to the smartphone. On both devices (USB in the car), many of the tags are not displayed correctly (i.e. genre).
Does anybody have a hint? TIA

The great question is: does you player support tags in wav files? A fair number does not.
You could try flac instead.

1 Like

Thank you for your time. The mystery is that on both devices (phone and stick), the tags work only in part, e.g. I have say 100 files tagged with genre "blues", the player on the phone finds 45, other genres appear 100% correctly. The stick does not even display certain items in the list of genres.
This is why I think some of those tags are broken.
All files had been (batch) tagged exclusively with the last 3 versions of Mp3tag.

Some players use the old conventions for the V1 standard for wav files. so it could be that some genres are user defined and not part of the original, byte-coded list.
If you use the files with 2 different players, each may have its particularities that lead to your observation. If Mp3tag shows the tags alright, I would investigate further what the players make of it and not what the tagger does.

Is it possible you have some songs with 24-bit resolution? These may not be recognized or playable in some players.

Sorry for the late answer. I have checked, but all files 16-bit.

I think you have to continue to look for differences or patterns why you observe this behaviour. E.g. find a file that is OK on the phone but isn't on the stick.
Or: filter for the files that have "blues" in GENRE and check whether it is really just "Blues" or e.g. "Blues " (with a trailing blank). The first could be part of the list of predefined genres whereas the one with trailing spaces would be a user-defined one which may not be supported by the player.

I think you are right on target. I do have several "hand-made" genres, some of which work OK with the smartphone but not with the car's reader. As for trailing spaces, I will check on this.
Thank you again.

You could filter for such files with
"$if($eql($len(%genre%),$len($trim(%genre%))),1,0)" IS "0"

Unfortunately not yet familiar enough with Mp3tag to know WHERE in the application to apply this filter. ;o)

Press F3 and copy & paste the above filter string and then press Enter.
Press F3 again to disable the filter function.

Thank you. Great, returns fields with preceding blanks as well.

You do not have to remove all the superfluous spaces by hand, you can let MP3tag do the job:
Select the filtered files.
Converter>Tag-Tag for GENRE
Format string: $trim(%genre%)
Click OK.
You may repeat that procedure for other fields like ALBUM, TITLE, ARTIST - use the same filter and converter but replace GENRE with the actual new field name.

Thank you again. Guess I have got the hang of it in the meantime.
Is there a dictionary of the possible commands somewhere?

I would check out the help on scripting and on actions