Getting everything the way I want it:

Hi there,

I've had a look round and I'm not sure I can see anything that resembles my problem - but I am spankers new to MP3Tag, so I might not even understand what's wrong in order to search for it...

Anyway, I'll try and describe the 'symptoms' of my what's going on so someone else can (hopefully) make some suggestions: basically, I've got my library organised so that I can look up artists or albums. I'm not interested in anything else - and that extends to soundtracks comprising multiple artists.

The thing that's pissing me off is that when I transfer the library from WMP to my Creative Zen, it often takes tracks by an artist, and files them under different names, seemingly 'contributing artist' or 'composer'.

In MP3Tag, I've only got 'Album Artist' and 'Album', so quite where the Zen getting the 'contributing artist' or 'composer' tag info from, I've no idea.

Example: Artist - Paul Simon / Album - Graceland / Track - Homeless
Zen: filed under artist as 'Ladysmith Black Mambazo'
Result - the track's missing from the album, and I can't find it, because I've often no idea where WMP/the Zen has hidden it. Ultimately, I can't begin to guess what other tracks have fallen foul of the same decision making.

Does anyone know where the process is breaking down? Is it WMP misreading or updating? Does the Zen make decisions based on hidden metadata? Is it just incompatibility between the different software/hardware?

Suggestions/advice/instructions all welcomed. I just want to find either an album or browse artists on the Zen.

Thanks in advance.

WMP (and so probably your ZEN master) needs the tag %band% filled as well. The "normal" artist (field %artist%) is displayed as "contributing artist" in WMP.
If %band% is left empty WMP adds those tracks to the dummy artist "no artist" or even "various artists".
So if by any chance the field %band% has been filled for some tracks it hasn't then the result would look like yours.

SO if you want to have a decent display under WMP you will not be able to avoid to fill %band%.

The forum is full of hints how to copy one field into the other - look for "format field" action.
I think you will need that to fill the %band% tag with the contents of the %artist% tag.

BTW: I have made good experiences wth entering a sort of dummy artist for soundtracks - called (amazingly) soundtracks. This groups all soundtracks and separates them form other samplers which then have the dummy artist e.g. "Sampler Jazz".
I hope, it helped. Have fun

Thanks for the info, mate. I need to learn more about the software, anyway, but will take your advice for a test drive. I'm sure it'll give me what I need.


Ok, all my 'Album Artist' tags are now filled. I wiped all 'Artist' and 'Composer' tags. But guess what?! WMP is still displaying all kinds of 'Composer' info. I can erase them using the 'advanced tag editor' but that'll take forever.

Do I need to 'update' WMP, or something? I know it'll sneak off to the 'net and bloody rewrite everything if I do...


You definitely need to turn OFF the option in WMP that allows it to add info to empty tags. You really don't want WMP making changes to your tag data behind the scenes.....

p.s. it doesn't take forever to remove all COMPOSER tags with extended tag editing. Simply load up all your files in mp3tag (use the top of your music file directory as the location), select all the files, right click, choose extended tags, and the tags you don't want for any file simply hit delete. A few mouse clicks and you can do the work for 100,000 files if you want....


Ah, I was talking about the extended tags in WMP. Didn't realise it was possible with MP3Tag. However, when I try it, I can't see a 'composer' or 'contributing artist' (see attached screen).

What I do wrong?


Hmmm, odd. Must be something that WMP is picking up from its own database. Have you cleared the files from WMP then readded them? I really can't help with WMP issues, as I don't use it at all for audio playback. Maybe someone else here with WMP experience has some thoughts.