Groß-/Kleinschreibung der Tag-Bezeichner


#1

Hallo Florian,

ich habe auch eine kleine Anregung.

Ich benutze derzeit die foobar2000-GUI "fooTunes", die in einem Info-Bereich die Tags anzeigen kann. Nun zeigt sie die Feldnamen allerdings nicht wie in foobar2000 üblich komplett in Großbuchstaben (also z.B. ARTIST) an, sondern so wie sie in der Datei stehen. Tagge ich mit foobar's Masstagger, dann schreibt dieser auf der einen Seite Album, Artist und Title, auf der anderen Seite aber auch RELEASE DATE und CATALOG NUMBER in die Dateien, was dann in der Ansicht natürlich nicht so schön aussieht.

Nachdem foobar2000 in dem Punkt also leider etwas unerwartet handelt, also einige Feldnamen in Großbuchstaben in die Dateien schreibt andere wiederrum nicht (Standardfelder so wie's aussieht), gefällt mir die einheitliche Kleinschreibung der Feldnamen durch Mp3tag schon eher und werde dieses Programm wohl wieder zum Taggen in Betracht ziehen. Noch besser gefallen würde mir allerdings eine Möglichkeit, die Schreibweise selbst festzulegen, damit die Bezeichner natürlich aussehen (also z.B. Artist und Catalog Number).

Deshalb schlage ich das jetzt einfach mal vor, vielleicht kannst du diesen Vorschlag realisieren falls er noch in das derzeitige Tagging-Konzept passt und du Zeit und Lust dazu hast.

Mit freundlichen Grüßen,

Frank


#2

Hallo Frank,

vielen Dank für Deinen Vorschlag. Ich bin zwar der Meinung, dass die Anzeige der Tag-Bezeichner unabhängig von der Schreibweise im Tag erfolgen sollte, da laut Spezifikation der Bezeichner bei APEv2 nicht case-sensitiv ist.

Nachdem man aber mit einer solchen Option sehr schnell Ordung in die verschiedenen Schreibweisen bekommen kann (und ein Tagger ja dafür da ist), habe ich im aktuellen Development Build unter Optionen, Tags eine neue Option für die Schreibweise der Tag-Bezeichner eingeführt.

Um die Tag-Bezeichner vorhandener Dateien anzupassen, kannst Du die Tags zunächst über [STRG+C] in die Zwischenablage kopieren und dann mit [STRG+V] unter Berücksichtigung der Einstellungen für die Schreibweise wieder in die Datei einfügen.

Viele Grüße,
~ Florian


#3

Vielen Dank Florian,

das ging ja schnell, was für ein Service. :slight_smile:


#4

Hallo Frank,

anscheinend hatte die Änderung ein paar Seiteneffekte, so dass ich den Development Build wieder zurückgenommen habe. Ich werde hier Bescheid geben, wenn ich eine Lösung für das Problem gefunden habe.

Viele Grüße,
~ Florian


#5

Hallo Frank,

mit dem aktuellen Development Build sollte nun alles wie erwartet funktionieren :slight_smile:

Viele Grüße,
~ Florian