Have to "allow" when I try to rename files

Hi @Florian

I've read through many threads on here. And I can't solve one minor issue I'm having.

I had to reinstall my MacOS - am on Big Sur (v11.6.8) - didn't have this issue previous to reinstalling.

When I use Tag - Filename - the first time, I get a prompt to "Allow access to filter to rename files"

I've tried the "defaults delete app.mp3tag.Mp3tag SecurityScopedBookmarks" that you've suggested others do with similar issues, but it doesn't fix it. I've even got mp3tag set up to allow Full Disk Access, but I still get the error.

What should I try next?

  • Thanx
  • Jon

Hi Jon and welcome!

The issue you're experiencing is due to Mp3tag being a sandboxed application. Sandboxed applications require explicit access to files and folders provided by the user via

  • an open panel, e.g., with โŒ˜O
  • Drag & Drop
  • Services

Mp3tag tries to remember once the permission is given via a "secure bookmark" (the list of them stored at SecurityScopedBookmarks as you already found out). This allows for editing the same files without subsequent requests for permission.

If you drag&drop or open individual files, Mp3tag only gets permission to edit those files. Renaming also requires permission to the enclosing folder. I believe this is what you're observing.

The good thing is, that those secure bookmarks apply to all included files and folders or a folder for which the permission is given. So if you choose a more general folder (e.g., your home directory at โ‡งโŒ˜H in the open panel), you can prevent future prompts for any of the containing files and folders. You can also cancel the reading process if it takes longer than acceptable โ€” Mp3tag will store the bookmark no matter what.

1 Like