Help!!! It really messed up - fatal bug?


#1

It's about Action - Format - _directory:

Everything was perfect with medium-size samples, so I proceeded to rename my larger collection (~40 GB, ~6000 files). After letting it running overnight (I need to define some new fields to rename), I ran the same action that I tested before. It basically turned out fine but with a lots of error messages and the program crashed a few times. But after that time, I run the same action with ~600 files, and it totally messed up.

The tags are correct, but the output of filename/path are all wrong. I wanted to rename in the format of album artist\album\track - title, but what turned out is:

album artist | album | the filename after running the action

artist1 | album1 | artist1\album1...
...
artist2 | album2 | artist1\album1\artist2\album2...
...
artist3 | album3 | artist1\album1....

Anyway, as in the second example above, there is absolutely no "artist1" or "album1" anywhere in the tag, so somehow mp3tag retained the information for the previous file and applied that to the next file?

I did not change the syntax in the action; the file/tag informations are basically in the same structure/format, what happen???

I tried uninstall mp3tag and reinstall it again, it does not change anything... What can I do?


#2

I think I figure out what the problem is: it is because of the annoying restriction to user access in Windows Vista. So when I tried to change even the folder name, a window pops up telling me that I don't have permission to do that?! I moved the files to another drive, and it solves the problem :slight_smile: