Help me migrate my library from MediaMonkey (back) to iTunes


#1

Hello,
In the past I have briefly used MP3TAG, I think I will/must use it again, to migrate my big 100.000+ tracks music library successfully back to iTunes.
I started it in iTunes, moved it to MediaMonkey when it became too big/slow for iTunes version 9 on my old pc, but after all many of my experiences with MM were very disappointing: the app looked like heaven but became hell - with thousands of messed up and damaged files, due to a very unreliable database structure.
So today I imported all files back in iTunes version 11 - which works lots faster than 9.
I experienced various importing problems and maybe MP3TAG users can suggest me how MP3TAG could help solve them.
1.
In MM around 98.000 of my tracks have content in the 'comments' field - i use it mainly for subgenres (blues, country, language). But after importing the tracks in IT only 5.000 comments have been imported. Why? And what can I do to correct it? Should I do a certain specific re-import? In the past (when I migrated IT to MM I noticed that IT uses the comments field (also) to store 'invisible' information. Maybe upon moving back this 'invisible' information has deleted my MM comments in most cases? Why? And which? And how to correct it?
2.
My MM has various fields that IT does not have - and that I do not find in MP3TAG either, when it reads my music directory. There is for instance the field 'conductor' (that I use for other info) and two user defined fields ? and ‚óŹ that I use for temporary edit checks and remarks. Is there a way with MP3TAG to 'import' the contents of these fields into MP3TAG and then move/copy them to certain fields in IT?

Thanks for helping!
Wim


#2

IT (as you call it) assumes comments marked as English - so perhaps MM marked them in a different language.
Check in the installation directory of MP3tag in the subfolder LANG in the LNG-File for your GUI language whether you find this line:
_M_STR_ID3V2LANG eng
If _M_STR_ID3V2LANG shows a different language then set eng and restart MP3tag.

If Mp3tag still shows the comments then you could copy&paste the tags with the special context-menu functions of the files list.
This should rewrite the tags with the proper settings. Try it with some files first.

As for the user-defined tags: as I do not know whether MM stores these only in its database or actually writes them to the files then the news is that MP3tag can read user-defined tags.
You find them in the Extended Tags dialogue (Alt-T). If Mp3tag does not show anything there then I am afraid it is hard luck.