Help with removing APE and writing ID3v2


#1

I was trying to get MP3Tag to save image data (if I used Discogs to look up the information it gets written, but when I try to manually drag and drop the album art, it doesn't save) using the advice I reach in the forums on removing APE tags. The problem is, once I do use the red "X" to remove the tags, I can only write ID3v1 tags afterwards, not ID3v2.

Here are my settings.

Mpeg:
Read: ID3v1 & v2
Write: ID3v1 & v2, (ID3v2.3 UTF-16)
Remove: ID3v1 & v2, APE

APE, Mpc:
Read: ID3v1
Write: ID3v1
Remove: ID3v1 & v2, APE

How can I erase the APE tags and make it so that I can write ID3v2 tags where there used to be APE tags?


#2

Weird. Normally when ID3v2 is selected in write, it also gets written.
Or do you have [ ] ID3v2 only if ID3v1 too small enabled?

If you only want to remove APE tags then only activate APE in "Remove"

MP3 files are only affected by the Mpeg settings.


#3

I think I figured it out. I think some .mpc files snuck into the mix and so that's why the ID3v2 tags wouldn't stick.