Hidden Track Field

I have an audiobook that has 10 disks. I want to listen to it in the car with my MPS player so I ripped it and used the auto numbering wizard to put all the tracks in sequence so I don't have to look for the next album/CD name while I am driving. The problem is that not all of the tracks got renumbered. They look fine in MP3Tag but when I played them some are out of sequence. I looked at the Properties/Detail in Windows and instead of the field name "Track" there is a field name "#" sign. The value in the # field is not sequential in the troublesome files. How can I find this hidden field name in MP3Tag and delete the entire field so that I can rerun the auto numbering tool and get the correct sequence?

You see all visible fields of a track in the "Extended tags" dialog: press Alt-T to open it.

I have tried that but it doesn't seem to work. Track 010 from disk 1, "song" 10 has
been renumbered. See image 01, clipboard from MP3tag. However when I look at
Properties/Details in Windows is shows up in the "#" field as 8 (image 02, clipboard from Prop/Det).
This is the track number that the MP3 player recognized. I have tried renaming and investigating
with APE clicked (Options page) and unclicked. When I look at "Customized Columns" the #
field is not present there either.

Any other ideas?

BTW is there a way to word wrap this forum message box?

Thank you.



Aha!
There is a bug in the Windows Explorer that interprets 3-digit-numbers as octal values instead of decimal.
so 010 becomes an 8 ...
If you reformat the tracknumber to 2 or 4 digits it should work.

I was just about to post that when I dropped the leading zeros the Prop/Det # went to 10.
The bad news is that it is not just Windows. I have a Creative Zen MP3 player and it
interprets it as an 8 also.

Thank you

As this only happens with leading zeros you just have to avoid them.
You can renumber the files starting fom 101 or even use a renumbering scheme using the first digit for the CD.
101 First track first CD
201 First track second CD