How to eliminate double entry in a field?

sometimes i get records with double entry in some fields. for example in the artist field it may be like this....jackson//jackson

i select the records and press alt T. and edit the tag items by deleting the extra entries. if i select multiple records nothing is being done. i have to select records one by one and make the editing. so if i have double entry in five records i have to do it five times. is it possible to select more than one records and make the editing by pressing ALT T ?

You can remove the field and set it to the desired value (e.g., Jackson).

but the suggestion is applicable if i have a particular album of a particular artist. if i have an album which contains various artists, and i do have the artist name twice as in my first post, how is it possible to delete and enter the new one for all artists? in that case i have to take each record seperately and to edit the field. by presssing ALT+T i can edit the entries of a single record. i f i select multiple records mp3tag doesn't do anything. i want help on this issue. thanks and have a nice day.

Given is a tag field ARTIST with content "Artist##Artist". You want to have the content to be "Artist".

You can apply an action "Format value" using the $regexp() function or an action "Replace using Regular Expression".

Actiontype 5: Format tag field
Field: ARTIST
Formatstring: $regexp(%ARTIST%,'^(.+?)##\1$','$1')

From: Artist##Artist
To: Artist

The exercise how to modify this example to use it with other separator characters is left to you.

DD.20100308.1220.CET

unfortunately it doesn;t work.
i have artist\\artist.
i applied as per instructions-format value
field aritst
format string as------->$regexp(%ARTIST%,'^(.+?)\\ \\1$','$1')
nothing is done!

There's an action "Remove duplicate fields"

Or change the string from DetlevD to
$regexp($meta_sep(ARTIST,##),'^(.+?)##\1$','$1')

1 Like

dear dano,

sorry to say that the regexp doesn't work. my seperator is slash.(artist\\artist title\\title etc) i replaced it and tried but the result was in the negative. since my seperator is backslash and there is a backslash in regexp itself. so there will be five backslashes and i doubt whether prog will recognise them properly. i tried with a space between two backslashes but find no improvement.

but to my pleasure the first option (remove dup fields)suggested by dano does work.

Try to learn how to differentiate between "forward slash" and "back slash" and how to use those characters as separators in Mp3tag.

German:
http://de.wikipedia.org/w/index.php?title=...;oldid=69929904
http://de.wikipedia.org/w/index.php?title=...;oldid=71439789

English:
http://en.wikipedia.org/w/index.php?title=...oldid=349319073
http://en.wikipedia.org/w/index.php?title=...oldid=349020884

DD.20100312.1201.CET

thanks to point out my mistake. i have backslash as seperator.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.