How to prevent double-click in file list

My good friend John suffers from Parkinson's disease which affects his ability to reliably click on something without frequently double-clicking when he didn't mean to do that.

When selecting one or more items in a column, he frequently double-clicks by mistake, which in turn launches the player associated with the file format—in this case, JRiver Media Center and the FLAC file format we have chosen as our default, go-to format.

When that happens, he cannot continue to edit the tags until he finds the JRiver "Stop" button and terminates the unintended playback. This makes the tagging process difficult and time-consuming for him. It's already a problem for him just to get the mouse pointer where he wants it. This only makes it worse for him.

I suggested he use the Tag Panel in conjunction with the Alt-T view for what he's doing, but he has his reasons for wanting to work in the grid view.

Is there a way within mp3tag to prevent it from launching the media player associated with the file format without breaking the JRiver Media Center/FLAC relationship outside of the mp3tag environment?

Thanks for any help. I'm sure John would appreciate it.

Dennis...aka "d2b"

He can disable the automatic double-click -> Default Player in the tools-menue. (Tools -> Options -> Tools)
There is a selection "Default Tool -> Use special program at double-clicks".
If he enables this without defining a program nothing happens with a double-click.

If he wants to play a song from the columns he still can do this with a Right-mouse-click -> Play

1 Like

Perfect solution! Thank you very much for your help with this problem. John will be very happy now.

Dennis...aka "d2b"

It's very difficult for John to wield a mouse accurately and even to identify the target upon which to click or double-click as the case may be. But to his credit, he's a very intelligent man with an advanced mathematics degree and as stubborn as a mule when it comes to overcoming his handicap. He will keep doing what he does, no matter what it takes to get it done. He and I work very closely together. Thanks again for your assistance.

Dennis...aka "d2b"

Thanks for the tip it works great!

Thread bump! Just came here looking for a way to disable the player. I find myself dbl clicking when I want to edit. This thread solved my issue.