How to send and drag & drop files to an audio editor? -OR- Problems with running as (not) administrator on Windows 10

I recently went from Windows 7 to Windows 10. And I have this problem: I can no longer drag and drop files from Mp3tag to Sony Sound Forge audio editor and I also cannot send them to it from via the Mp3tag Tools > Options > Tools feature

The problem comes to this: one software is run as administrator and the other is not. At least that is the explanation that I have found on the Internet to this apparently common problem with various pieces of software; and which explenation is confirmed by my tests


On my system I have one User and that User is the administrator. I have Mp3tag pinned down to the Windows Taskbar. The Mp3tag icon on Taskbar has 2 playlists pinned to it. And by default it works like this: if I want to open Mp3tag I can either left click the main icon on the Taskbar or right click the very same icon to unfold the short menu- and then left click one of the two playlists or the additional icon for the Mp3tag EXE itself. So after that, in either case, if I have files in the main window of Mp3tag and want to select them and drag them to my audio editor I can do that only in theory- because in reality nothing will happen [except for an occasional show up of the hour glass for a split second]. Also if I execute the simple Tools > Options > Tools entry

Path: C:\Program Files (x86)\Sony\Sound Forge 7.0\forge70.exe

Parameter: "%_PATH%"

then also nothing will happen. My actions are simply ignored. And both of these methods were working on Windows 7 without a problem. But there is a solution to this; kind of...


If I right click the Mp3tag icon on the Taskbar and then also right click its icon from the mini-menu, I can go to its

Properties > Shortcut > Advanced > Run as administrator

and select the box for that. So now what happens? If I left click the icon on the Taskbar [or right click it and the left click the sub-icon] Mp3tag will open- and I can drag files to my editor from it. And I can also execute my Tools > Options > Tools shortcut. So, the problem is solved? Well, not exactly


Because if now I will right click the icon on the Taskbar to see the menu and left click a playlist from it- nothing will happen. So now the task of loading of the playlist is ignored. And there is no

Properties > Shortcut > Advanced > Run as administrator

path for the playlist to be tempered with- at least not accessible in the same way as in the case of the shortcut to the EXE. So I navigated myself directly to the

C:\Program Files (x86)\Mp3tag\Mp3tag.exe

I hopes of selecting Run as administrator for the EXE, instead just for the shortcut. The path to came out to be different, because it goes like this

Compatibility > Settings > Run as administrator

So, problem solved? Not exactly


Because:

A] Now if I right click the icon on the Taskbar and then left click a playlist from the mini-menu, I will get an pop up question from the User Account Control, prompting me if I want to execute it. So Mp3tag icon works and playlist icons work- but the latter ones now in an inconvenient way. It is simply a drag to re-click that UAC question every single time when I want to load up a playlist from a shortcut

B] If I want to play files from Mp3tag in my Winamp, I can double left click a single file in the main window or select in the main windows multiple files and use the Play option from the right click menu- and then have to wait for about 20 seconds before Winamp will finally start to play the loaded data. And what is also interesting, during this 20 seconds Mp3tag works half-way, e.g. I can execute an Action but then will have to wait for the Mp3tag Toolbar icons to regain their colors thus indicating that the options from the Toolbar are no longer blocked [by that sending process that last ~20 seconds]. And what is more interesting, if in these new conditions [with Run as administrator applied directly to the EXE] I drag and drop the files to Winamp from Mp3tag, there are loaded into the playlist immediately

The same thing [the "B]" that is] happens with FreeCommander file manager: I cannot drag and drop files from it unless FC is opened as administrator- and when it is, it takes ~20 seconds for a file left-clicked in FreeCommander to be played in Winamp and during these 20 seconds FC blocks itself [but completely and not just kind of like inthe case of Mp3tag]. So I should also run Winamp as administrator- and the problem will be solved [because I will have an administrator combo consisting of tagging, file managing and audio playing software]? Not exactly

Bacause if Run as administrator is applied to the Taskbar shortcut of Winamp- playlists pinned down to Winamp Taskbar icon will be opened in new instances of this software; and when Run as administrator is applied directly to the EXE of Winamp- the same User Account Control drag will be happening as with playlists pinned down to Mp3tag icon [that "A]" thing]


So you see: this is getting ridiculous. This problem solved in such way in one place / software pushes it to another place / software. [And in the future I might want / need to expand my software combo by some additional program, thus continuing this run-as-administrator cascade]


And before I ask for solutions, three things I must point out, that might be beneficial to resolving this matter

1] How is it possible that Winamp not run as administrator will after ~20 second succumb and play a file send to it from a software [like Mp3tag or FreeCommander] that is being run as administrator? My good old Sound Forge does not succumb at all. And why does Winamp not need 20 seconds when files are dragged from a software to it, but immediately lists them in a playlist when there are dropped?

2] Sound Forge is not run as administrator- at least not to my knowledge. Its EXE file does not have the Run as administrator check box selected, just like a shortcut for it that was placed in the Menu Start. Why does Mp3tag [and FreeCommander] when not run as administrator apparently want to open Sound Forge as administrator [I assume, because if they would try to open Sound Forge not as administrator then the files would be send to it without a sweat, right; and I wolud not have a need to post this?]

3] In comparison I can send files to spectrogram software called Spek from both Mp3tag and FreeCommander, no matter if they are run as administrator or not. But that is because Spek does not install itself, but it is just an EXE ready for usage as it is. The Tools > Options > Tools entry for it goes like this

Path: C:\Windows\System32\cmd.exe

Parameter: '/Q/D/U/C START "SPEK" /MAX "C:\Program Files\Spek\spek.exe" "'%_PATH%'"'



So my questions / solutions would be:

I] How to run every software as administrator? And why is not every piece of software already being run as administrator if I am the administrator User of the operating system?

II] How to run all playlists files as administrator? Or how to run as administrator just the playlists pinned to the icons of software pinned down to the Taskbar [as I do not use playlists other that these particular ones and in that very exact way as described]

III] How to get rid of the User Account Control pop up questions? On Windows 7 once a software was allowed to be run by the user, it stayed with that privilege for good. But our good old Microsoft had to improve things by treating us as idiots, that cannot be trusted with the choices we make

IV] How do I check which software at a given moment is being run as administrator and which is not? I do not see such info in the Task Manager


I am using Mp3tag 2.97, FreeCommander XE 2019 Build 790a 32-bit public, Sony Sound Forge 7.0 Build 214 and Winamp 5.8 on Windows 10 Enterprise x64 18362.239

Some picked out answers to your veeeeery long post:

Security reasons. Have a look at the access rights for folders and files. Your "Administrator" user is only one of the many possible users who should have access (others are "Trusted Installer", "System" and some more).

Type uac in the search field (magnifying glass in Taskbar) and adjust your needed level of security. Everything lower then "Standard" increase the risk of unauthorized access from a virus and malware.

Choose the tab "Details" in the Task Manager and search for your app, like Mp3tag.
Then you can read the actual user name in the column "username" and check to see if it is running with Elevated Privileges. You can choose which columns should be displayed by right clicking on one of the column headers.

I would seriously check the ownership of the files.
Esp. if you have a new installation of the OS but the files reside somewhere else, it is most likely that you are not the owner anymore.
Being administrator is not enough.

some technical backround:

https://docs.microsoft.com/de-de/windows/win32/api/winuser/nf-winuser-changewindowmessagefilterex?redirectedfrom=MSDN

but it's not recommended, see

https://blogs.msdn.microsoft.com/patricka/2010/01/28/q-why-doesnt-drag-and-drop-work-when-my-application-is-running-elevated-a-mandatory-integrity-control-and-uipi/