In a Web Sources script, having [] characters in "IndexUrl" results in: "Error connecting to server - provided uri is invalid"

The issue is that, in a Web Sources script, having [] characters in IndexUrl results in:
Error connecting to server: provided uri is invalid:

 
In details:
I'm trying to modify the Metal-Archives web source script in order to display all versions (CD, cassette, vinyl) of an album, not just the first match.

That's why I tried to append to IndexUrl in its line 28 the following:
releaseFormat[]=CD&releaseFormat[]=Cassette
i.e.:
to become

[IndexUrl]=https://www.metal-archives.com/search/ajax-advanced/searching/albums/?releaseFormat[]=CD&releaseFormat[]=Cassette

but unfortunately I'm getting e.g. this:
2024-02-10_012112

And, If I omit the [] chars, i.e.

[IndexUrl]=https://www.metal-archives.com/search/ajax-advanced/searching/albums/?releaseFormat=CD&releaseFormat=Cassette

then I don't get the above error, but that URL is wrong and naturally returns no results:
Screenshot 2024-02-10 125123

I also tried escaping these characters with backticks `:

[IndexUrl]=https://www.metal-archives.com/search/ajax-advanced/searching/albums/?releaseFormat'[]'=CD&releaseFormat'[]'=Cassette

but the backticks are unfortunately included in the produced URL instead:
Screenshot 2024-02-10 131033

Using 3.24 (or 3.24a) x64 on win11.

Thank you

Me&tal Archives#Search by Band + Album (non-working).src (5.3 KB)
Me&tal Archives#Search by Band + Album (original).src (5.3 KB)

What happens if you try it with the encoded values like
%5B%5D
for [ and ]?

[IndexUrl]=https://www.metal-archives.com/search/ajax-advanced/searching/albums/?releaseFormat%5B%5D=CD&releaseFormat%5B%5D'=Cassette

I'm not sure why you use an ending apostrophe in your .src file for IndexUrl, but that seems to be necessary to find something?

1 Like

Yes, with the encoded values %5B%5D it's working fine, thanks a lot!

That ending ' was kept by mistake, sorry. So the following is working fine:
[IndexUrl]=https://www.metal-archives.com/search/ajax-advanced/searching/albums/?releaseFormat%5B%5D=CD&releaseFormat%5B%5D=Cassette

So, I don't know if my report is considered a bug( or rather a feature request), or if it works as expected?
I mean, is percent-encoding is the way to go in such cases, or it would it be possible to also support [] characters in IndexUrl? (kindly cc @Florian)

1 Like