? in filter string


#1

Anyone know how I can get the filter string to show files with the character ? in the field? Simply entering ? fails - it appears that ? is secretly reserved for some special meaning, presumably windcard. (V2.35a)

Also suggestion to developers: cover the filter string in Help.


#2

The filter uses regular expressions, you must escape certain characters.
Use ?


#3

Thanks.

Likewise other characters needing that workaround are: . * ^ $

Developers: please document! :wink:

PS Any idea what filter

Field: /

is for?


#4

There's no / filter by default, maybe once you entered this as a new tag field by mistake.
The entries in the filter are also derived from the fields you get when you make a new tag in the "Tags..." dialog.


#5

Thanks.

maybe once you entered this as a new tag field by mistake.

If so, how does one delete it?


#6

You can edit the registry or in the latest version, there's a Shift+Del shortcut.
Registry:
HKEY_CURRENT_USER\Software\Moebius\Mp3tag\Settings
The string TagFields holds all the entries.

Shortcut:
Go to the :mt_tag: "Tags..." dialog and click on the :mt_new: button. Now choose the field you want to remove and then press SHIFT+DEL.
Then choose any different field and enter a value and press the OK button (this is important).
Back in the "Tags..." dialog, hit Cancel and restart the program.


#7

Belatedly, thanks Dano - that worked fine.