Issue with Text file - Tag

Issue Summary:
I have a Text file the updates the comments tag and a custom tag called "playlists" based on the full file path. There are about 4000 entries in the text file. When I used the "Text file - Tag" feature it successfully updated all of the files except 30 or so. I am trying to figure out why those 30 did not update.

I singled in a one file. If I can figure out what is causing this file to not be updated, I suspect that I will know how to fix the others.

When I try to load the text file I receive the following error:
No matching entry for file "C:\Users\Cody Sechelski\Google Drive\My Music\Daniel Tiger's Neighborhood\PBS KIDS Presents Daniel Tiger's Neighborhood\01 - It’s a Beautiful Day in the Neighborhood!.mp3".
:frowning:

More info - Optional reading
The point of all of this is to stamp each mp3 file with as semicolon delimited string of playlist names. I wrote an application that will read all of my playlist files and generate a text file in the correct format to update a custom tag called "playlists" and the comments tag with a string that represents all of the playlists that the file is a part of.

This is helpful because I keep my music collection in google drive and use several different apps on several different platforms to connect to it. Not all music apps allow me to import a playlist, but most of them do allow for the creation of smart playlists. So I can set up a smart playlist called "Favs" for example where the comments tag contains "playlist:Favs". My ultimate goal is to use one application (Music Bee on my PC) to manage my playlists and have all of the other applications (iTunes on my wife's computer, Plex on my HTPC and Cloud Player on my Android) will pick it up.

So far I have it almost completely automated. I created a windows app that will monitor my playlists folder and if anything changes, it will generate a new text file that can be loaded into MP3Tag. I wish there were command line options within MP3Tag that I could call to fully automate it. Maybe someday :slight_smile:

EDIT: Sorry for the giant screen shot images

I do not have an immediate answer, but questions and remarks.

  1. Are you aware that there are different types of apostrophes envolved? --> ' ´
  2. Please show us the formatstring from the dialog "Text File - Tag".
  3. How long are the filepathnames, when writing a file to disk?
  4. The single apostrophe ' is a special character in Mp3tag and needs escaping. --> ''

DD.20151119.2030.CET

I tried to re-produce that behaviour but could not.
I created a file with the same path and could update it using "Text file - Tag".
The only time I saw that error message was when the file specified in the text file was not loaded in Mp3tag.

My only suggestion is to test with a new, nearly identical filename and/or path.
Maybe there are some oddball characters that are hard to spot by eye.

The apostrophe in "It's a Beautiful Day in the Neighbourhood!.mp3" looks suspicious.
It's different from the 2 other apostrophes in the path.

Thanks DetlevD and ryerman,

Yeah, I tried normalizing the apostrophes. to use a single quote character and it did not fix it. It seems like there is something wrong with the file it's self. I created a copy of the file in a different directory and replaced the original file with the copy. Same exact file name. And it worked.

That's the good news. The bad news is that it does not help me identify the root cause. While playing with other files that did not work, I am able to manually set the tags in MP#Tag so it's probably not a file permission issue. I'll keep digging deeper and see what I can figure out.

It sounds strange that it would work with a copy but not the original.
Maybe it's futile, but you could attach a copy of the problem file, or provide a link to a download site.
Maybe somebody can spot a problem.