It sets a cover description for me, even if I don't want one


I've recently moved from the 32bit version of the software to the 64bit version, so I'm not sure if this is a new bug, or just something that's in the 64bit version.

When I add new artwork to a file, then save, the artwork is automatically given a cover description: 'Cover Art (Front).jpg'. This description isn't there before I save the tag.

It does this whatever the name of the file is/was - it's not picking it up from the file I've added. I've found a workaround, where I just manually add a cover description, even if it's just a single space, but clearly this is not a good long term solution!

Thanks for this software, and your time in reading this.

As this does not happen here?
How do you add cover-art to a file? Do you talk about using a websource or an import action or a manual adding of a local file?

So you get an external file? Usually MP3tag only deals with embedded metadata.
I assume that you get this behaviour when you retreive information with a web source?
See the Utils button at the bottom to select the options what to do with retrieved cover art. There you can also set to only embed the picture and not save it to the file system.
Also, see Ctrl-O the Options>Web sources which format string you have set to generate a filename for an album cover. You should set something that produces a valid filename.

This is the default behavior when adding cover art to APEv2-tagged files. The APEv2 tag format doesn't have a dedicated field for cover types (front, back, ...) so it's a kind of quasi-standard to use the cover description for that.

If you don't need APEv2 tags (and almost nobody does and assuming you're using this with MP3s), please see Options → Tags → Mpeg to disable reading and writing of those.