iTunes tag


#1

Hi,
I've got a couple of questios about tagging and iTunes.
Firstly, I use iTunes to play music and I had been tagging and adding artwork etc. using the Idv2.3 ISO-8859 option and the unicode characters was displayed as ???. I changed the ID option to UTF-16 and now the unicode characters are displayed correctly, but at the loss of the album artwork that I've added before. Questions: Why is the artwork lost? I thought it had been saved onto the tag so it would be there no matter what form/type the tag takes? I really don't understand it, since artwork is the only thing I lose while lyrics and other info are still intact.

Another problem that I've been having is that changes in the tags made using iTunes are not reflected in Mp3tag, so I have to retag them again on mp3tag to match what I've done on iTunes. Why is this so and is there any way for mp3tag to automatically follow what I've done on iTunes?

Thanks


#2

Did you add covers to the MP3s using Mp3tag or did you let iTunes download covers?


#3

I copy and paste artwork using iTunes. I don't download artwork.


#4

I don't have any of your problems.
What's your iTunes version?
Do your mp3 files have APEv2 tags?


#5

I'm using the latest version of iTunes, v 7.0.2 if I'm not mistaken. What sort of types of tags does it use?

Yes, some of my songs are of the [Apev2 (id3v1 id3v2.3 Ape v2)] variety. Actually, it would be great if you could tell me how to remove Apev2 tag from those songs. I have a feeling that the source of my problem is the APE tag. I did try to save the tags again after I unticked the WRITE APE v.2 function in the preferences menu, but the tags still have Ape v2.

Cheers
lisa


#6

In this part of the options there is also a "Remove" section.
Only check the APE box!

Now you can use the "Remove Tags" command [Ctrl+R] to delete only Ape tags.

If your mp3 files have id3v2 and ape tag, then Mp3tag displays the ape tag. If you make a tag change in itunes it updates the id3v2 tag only and if you check the file then in Mp3tag you see the unchanged ape tag.
So better stop using ape tags.


#7

Wow... that actually works. Thanks for the tip, dano!