iTunes won't read AAC tags

Hello everyone,

Hoping someone can help, as I've tried everything with no success. I just used Mp3tag to edit the tags on a bunch of AACs I purchased on iTunes. Before doing so I removed them from iTunes, so now I am trying to import them back into iTunes.

However, when I move them back in, iTunes doesn't read the tags as I've changed them—it uses the original tags as they were when the song was purchased.

I've noticed that if I look at the info for a song, it will update to the new tags...but this is not practical for a lot of songs.

How do I get iTunes to read the new tags when I import the songs?

I have tried everything I can think of, including: (1) Changing read/write/remove settings and saving/deleting (suggested elsewhere on the forum); (2) Cutting & pasting tags (suggested in the FAQ); (3) Removing iTunes metadata from extended tags; etc.

Any help or suggestions would be much appreciated. Thank you!


You have to delete the files from the itunes library ("Do you want to to delete the files to trash or only from the library?") and import them again.
Also, there are scripts around that force itunes to re-read the file information (and remove orphaned entries, if you want).

PS: Isn't this a topic for the iTunes forum?

Thanks for your response ohrenkino. I have already deleted these files from the library before changing all the tags, and when I re-import them iTunes still displays the old tags. Alternatively, I have tried importing the new files, deleting those, and then re-importing again, and it still displays old tags.

I will look into finding a script, as it seems like the only viable option.

Also: I apologize if this is in the wrong forum. I assumed the issue came down to how Mp3tag works and handles tags (and that any fix would be through Mp3tag), so I thought this forum would be most appropriate.

What does MP3tag display then? MP3tag will probably only deal with information that it can show.

Still: some AACs in Nero format cannot be dealt with.
e.g. see this post about the Nero codec:

It could be that you have 2 tags in the files, one normal and one from Nero. The Nero one cannot be editted, only deleted.

Not sure whether there was a Nero codec involved, but the link was very helpful and I think I've found a solution that will work. After a couple of tests it seems that exporting all the tags, deleting them from the files, and then importing the tags from the text file gets rid of whatever leftover tags were causing the problem.

Thank you for your help!