Keine Tags nach Einlesen


#1

Hallo,
ich habe seit der Version 2.47 das Problem, dass bei den eingelesenen Dateien keine Tags angezeigt werden. Diese sind aber vorhanden, habe sie selbst mit einer älteren Version geschrieben.
Wenn ich diese Dateien mit dem Programm PureMP3 bearbeitet habe, werden die Tags alle richtig angezeigt.
Komisch finde ich es nur, dass auf meinem MP3Player auch alles angezeigt wird.
Habe ich vieleicht eine neue Einstellung übersehen?

Gruß
Udo


#2

Könntest du mal unten rechts in der Statuszeile checken, wieviele von wievielen Dateien er anzeigt?
Wenn da sowas wie 0/2395 steht, hast du wahrscheinlich einen Filter aktiv. Lösche dazu die EIngabe bei Filter.


#3

Ich habe keinen Filter eingeschaltet.
Es wird unten rechts z.B. folgendes angezeigt:
103(07:14:09 ! 1009,0MB)
Die Anzahl der Dateien stimmt.

Gruß
Udo


#4

Der nächste Schritt ist, zu prüfen, welche Tag-Typen in einer Datei vorhanden sind und welche in den Optionen von Mp3tag zum Lesen eingeschaltet sind.

Was zeigt die Spalte "TagRead (TagTypes)" in der Listenansicht an?
Wenn diese Spalte nicht angezeigt wird, dann diese Spalte im Dialog "Mp3tag/Ansicht/Spalten" zur Ansicht einschalten.

Wenn die Spalte dort nicht konfiguriert ist, dann diese Spalte hinzufügen.
Name: TagRead (TagTypes)
Wert: %_tag_read%[ (%_tag%)]
Feld:
Sortieren nach:
Numerisch:

Alternative:
Den Dialog "Erweiterte Tags..." für eine Datei öffnen [Alt]+[T] und in der Titelzeile des Dialogs lesen, die mit "Tags" beginnt, welche Tag-Typen zwischen den beiden Minuszeichen aufgezählt sind.

Dann den Dialog öffnen "Mp3tag/Extras/Optionen/Tags/Mpeg" und die Lesen/Schreiben/Entfernen Optionen dem Tag-Typ in der Datei bzw. den Daten entsprechend einstellen.

Anschließend sollten die Werte aus dem gelesenen Tag-Typ in der Listenansicht zu sehen sein.

DD.20110411.1111.CEST


#5

Ich habe mir beide Dateitypen, die wo Tags angezeigt werden und die wo nicht, angesehen.
Die nicht angezeigten sind vom Typ APEv2(ID3v1 ID3v2.3 APEv2).
Die die angezeigt werden haben den Typ ID3v2.3(ID3v1 ID3v2.3).
Zum Lesen, Schreiben und Löschen sind alle Haken gesetzt. Beim Schreiben ist noch ID3v2.4 UDF-8 selektiert.

Gruß
Udo


#6

Ach ja, die guten alten APE-Tags!
Die machen eigentlich nur Ärger.
Stelle bitte beim Lesen und Löschen APE ein, beim Schreiben aber nur MP3 2.3V3.

Auch würde ich keine V2.4 Tags schreiben, da die auch in der Kompatibilität Ärger machen.
Dann schneide bei den APE-belasteten Dateien die Tags aus und füge sie gleich wieder ein. Dann sollten nur V2.3-Tags enthalten sein und alles gut werden.
(das hat übrigens nicht so richtig was mit MP3tag zu tun, sondern mit den Dateien an sich)


#7

Verstehe ich es richtig, dass du die Lösung schon gefunden hast?

Wenn es noch unklar sein sollte, dann stelle die Optionen so ein ...

  • Read
    • [x] ID3v1
    • [x] ID3v2
    • [_] APE
  • Write
    • [_] ID3v1
    • [_] APEv2
    • [x] ID3v2
      • (_) ID3v2.4 UTF-8
      • (x) ID3v2.3 UTF-16
      • (_) ID3v2.3 ISO-8859-1
      • [_] ID3v2 only if ID3v1 too small
  • Remove
    • [x] ID3v1
    • [x] APE
    • [_] ID3v2

Mit dieser Einstellung bekommen die Dateien die größt mögliche Kompatibilität mit dem Windows Explorer.
Der Tag-Typ ID3v1 wird zwar gelesen, falls kein anderer "höher wertiger" Tag-Typ vorhanden ist (ID3v2, APE), aber er wird nicht geschrieben und wenn vorhanden, dann entfernt.
Der Tag-Typ APE wird von Mp3tag als "höher wertig" gegenüber ID3 Tag-Typen behandelt und verdeckt eventuell vorhandene ID3 Daten. Der Tag-Typ APE führt immer wieder zu Verständnisfragen und technischen Problemsituationen (wie hier nun auch wieder) und sollte deshalb rigoros aus den Dateien entfernt werden.
Wenn im APE Tag wichtige Daten gespeichert sind, dann sollte man diese mit der Mp3tag Export Funktion exportieren und anschließend in den ID3v2 Tag-Typ importieren, und schließlich den APE Tag komplett entfernen.

DD.20110411.1158.CEST


#8

Danke für die schnelle Hilfe.
Habe meinen Einstellfehler nun gefunden.
Beim Lesen darf ich APE nicht eingeschaltet haben, dann wird automatisch ID3v2.3 gelesen und siehe da alles ist da.
Ich habe beim schreiben auch das APE abgeschaltet.
Noch eine Frage: Welches ID3v2.3 soll ich benutzen? Es gibt zwei Ausprägungen: UDF16 und ISO.

Gruß
Udo


#9

Guckst du:
/t/2786/1