Kompatibilität 2.36a <> 2.25?


#1

Hi,

auf meinem Desktop-PC benutze ich die Version 2.25, bin zufrieden damit und habe mich nicht weiter um Updates gekümmert. Auf meinem Laptop habe ich nun kürzlich die neueste Version 2.36a getestet und damit ein paar mp3's bearbeitet.

Als ich nun diese mp3's auf den Desktop-PC überspielt habe und sie mit 2.25 geladen habe, mußte ich zu meiner Verwunderung feststellen, dass die Felder, die ich mit der Version 2.36a bearbeitet hatte (Titel, Interpret, Album, Kommentar) nicht erkannt werden. Andere unbearbeitete Felder (z.B. Bitrate, Länge, Codec, Frequenz) werden problemlos erkannt.

Was ist hier passiert??? Gibt es hier ein Kompatibilitätsproblem oder habe ich einen Einstellungfehler gemacht?? :unsure:

Danke & Gruss
Bangus


#2

Benutze ID3v2.3 ISO-8859-1 auf deinem Laptop.


#3

Hallo Sebastian, danke für die schnelle Antwort.

In meiner Version 2.25 gab es die Option "ID3v2.3 ISO-8859-1"noch nicht, daher hatte ich nicht darauf geachtet. Leider habe ich meinen Laptop derzeit nicht bei mir, kann erst morgen prüfen, welche Option dort eingestellt war.

Ich habe aber nun mal probehalber v2.36a auch auf dem Desktop installiert (parallel zu 2.25). Dabei habe ich festgestellt, dass obige Option defaultmaessig aktiviert war. Eigentlich hätte "nichts böses" passieren sollen... :astonished:

Ich habe also nun besagte mp3-Dateien in 2.36a eingeladen, im Kommentarfeld eine leichte Modifikation vorgenommen und auf SPEICHERN geklickt. Danach die 2.36a geschlossen, die 2.25 gestartet und genau diese soeben geänderten Dateien dort eingeladen.

Die gute Nachricht: Die Tags sind nun in 2.25 wieder lesbar.

Die schlechte Nachricht: im Kommentarfeld passieren merkwürdige Dinge. Dort stehen andere Werte, als die, die ich eben eingegeben habe...! Lade ich die gleichen Dateien wieder in 2.36a, werden die korrekten Kommentar-Daten angezeigt, gemäß der Modifikation von vorhin.

Bin etwas ratlos... :flushed:

Gruss
Bangus


#4

Evtl. haben die Dateien auch APEv2 Tags, die von der anderen Version nicht gelesen werden (Einstellungssache)?


#5

Glaube ich eher nicht, da es sich um reine mp3-Dateien handelt. Ausserdem habe ich APE sowohl bei der v2.25 als auch der v2.36a weder bei Schreiben, Lesen oder Entfernen aktiviert.


#6

Kannst du das genauer beschreiben?


#7

Ja, gerne!

Ich habe eben folgenden Test gemacht:

  • verwendete SW: v2.25 und v2.36a (in Optionen ist jeweils ID3v1 und ID3v2 ÜBERALL mit Häkchen versehen, bei 2.36 zusätzlich ISO9950-1 aktiviert).

  • mittels Line-in Aufnahme habe ich ein jungfräuliches mp3-File erzeugt.

Schritt 1:
Nun lade ich dieses File mit Version 2.25 und schreibe in das Kommentarfeld "225".
Das Feld ist in beiden Versionen 2.25 und 2.36 lesbar.

Schritt2:
Ich lade 2.36a und ergänze das Kommentarfeld um den String "236".

Ergebnis:
in 2.36a steht nun "225236", in 2.25 steht"COMMENT:" und der eingegebene Text ist weg. Gehe ich wieder zurück nach 2.36a wird das Kommentarfeld korrekt angezeigt.
Die Felder Titel und Interpret, wo ich in 2.36a auch Werte eingetragen hatte, erscheinen in 2.25 leer. Im Windows Media Player oder iTunes, werden die Felder Titel/Interpret korrekt angezeigt.

Wie gesagt, dieser Test passierte eben mit einem jungfräulichen File. Bei den anderen Files gestern gab es nur Probleme im Kommentarfeld. Nach Neu-Abspeichern der Files mit 2.36a bei aktivierter Option waren alle Felder in 2.25 lesbar, nur eben das Kommentarfeld verhundst.

Was mir noch aufgefallen ist: bei mir wird die Spaltenüberschrift "Länge" falsch angezeigt. Da steht oben "Lu00e4nge". Ich habs manuell geändert, aber schon irgendwie komisch...

Ich hoffe, Ihr könnt meine Beobachtungen nachvollziehen, irgendwas ist da faul...

Ich könnte ja nun einfach komplett auf 2.36a umsteigen. Ich habe aber jahrelang (!) mit der 2.25 gearbeitet uned Tausende Tags damit bearbeitet, irgendwie beunruhigt mich das ganze doch etwas - wäre schade, wenn die ganze Arbeit vergebens gewesen sein sollte...

Gruss
Bangus


#8

Das Installieren von 2 verschiedenen Mp3tag-Versionen auf einem PC ist nicht sehr ratsam, das sie auch auf die gleichen Konfigurationsdateien zugreifen.
Dabei kann dann sowas wie mit der Spaltenüberschrift "Länge" wie bei dir passieren.
Entscheide dich also für eine Version.

V2.25 ist auch schon 2 Jahre alt, wenn da teilweise Tags von der neuen Version nicht gelesen werden, muss man das hinnehmen. Mit Problemen von so alten Versionen möchten wir uns eigentlich nicht rumschlagen.

Sehe eigentlich keinen Grund nicht auf die neue Version umzusteigen


#9

OK, wenn es keine Bedenken gibt, werde ich das machen. Die neue Version erscheint mir auch sehr stabil und v.a. viel schneller als die alte! :slight_smile:

Gruss
Bangus