Lan Trouble (file cannot be opened)

About every 4th file (its actually random, but it happens alot) seems to say File "x:\rock\band\album\songname.mp3" cannot be opened for writing. Do you want to continue?

This only happens to the files on my media server, or other computers. It does not happen if they are on my hard drive, but it is impractical to download all files just to edit tags and then stick them back on the network somewhere.

I know the file is not actually locked, as if I do the tagging in lots of 2 or 3 files at a time, I almost never have that error message. However, if I try to do 4 or more, I am almost guareenteed to get the message. I have tried other software and had zero errors (but their software is not as good/flexible as mp3tag).

To do a double album of say 30 songs, I have to edit the files up to 10 times just to get the album art/or common info (e.g. band name) to stick.

Incase this is important, my process is, highlight all the files in Windows Explorer that I want to edit --> right click and select MP3TAG. In mp3tag I highlight and select all, add album art (if not already done), and edit common fields (band, genre, etc), and click save.

Anyway to overcome this constant error?

How do you know that? Do you have a tool that shows which programs access that file?
E.g. the Windows Explorer (and the description of how you work indicate that) tries to create/update its thumbs.db. So it could be that even the Explorer collides with MP3tag.
Also, if you have a gadget running that shows pictures this could call the WMP in the background which then in return may watch the folder you are currently accessing.

Have you tried to work with MP3tag alone by using the built-in functions to open a folder?
(It is very hard to give sound advice from the distance without having an unblocked view on the setup.)

How do you know that?
Because if I try to save multiple files, then pass 1, file 3 might have the error, but pass 2 file 4 might say that error. Plus as the network admin, I have access to the file as admin, so I can see that it is not read only via Windows Explorer and via Synology Diskstation (if on media server).

Is disabled (i.e. I do not create them). I know this is disabled as Synology Diskstation would show the thumbs.db files when they used to be created last year.

if you have a gadget running
Not sure if you mean just Windows gadgets, I dont have that turned on. Also, I do not have any other programs running in the background except my display drivers (ATI), Rivatuner, and Logitech Setpoint (I dont let programs start with windows unless I want them 2), and 1 windows explorer window so that I can edit the files/jpg's etc.

Have you tried to work with MP3tag alone by using the built-in functions to open a folder?
Okay. So instead of right click starting mp3tag editor, I started mp3tag editor from the start menu, and then used "change directory", and wallah, no errors for the last 11 cd's.
This is the way I will have to do it atm, but thats ok, still good to have no errors. Thank you for the suggestion.

Thank God, we found a way.
The reason why Iasked so many questions: I think that software is generally evil ;-).
E.g. in Windows 7 I frequently have trouble to delete a directory with mp3s in it because the windows explorer wouldn't let me delete the thumbs.db which the explorer creates for the display in the status bar. For some reason winodws caches that access pointer so that I have to do a lot in between to flush that cache and finally be able to delete the otherwise empty folder. In the meantime windows insists that it cannot delete the folder because "some other" program blocks it. And this does not have to do anything with access rights as admin but with the internal aging of file locks.
So that is why I was a little reluctant to accept the statement that no other program was accessing the files.
Right now, it looks to me as though the windows explorer is the culprit: as long as there is an explorer window open that shows the files under modification it causes these blocking errors.
Thanks for trying the alternative method.