Lückenhafte Tags


#1

Hallo Freunde!

Erstmal dickes Lob und vielen Dank für diesen Bereich!

Ich habe folgendes Problem, was auch durch Neuinstallation nicht behoben wurde (habe auch Beta Version 2.27g installiert)

Wenn ich Verzeichnisse einlesen möchte werden mir bei manchen Tracks nicht alle Angaben angezeigt.
Meißtens handelt es sich um Album oder Genre. Obwohl die Daten vorhanden sind...

Ich habe im Windows Media Player mal im erweiterten Tag-Editor nachgesehen. Ich habe Spaßeshalber bei zwei Dateien bei "ursprüngliches Album" mal Hallo eingegeben und es übernommen, aber keine Änderung. Dann habe ich das wieder gelöscht, wieder übernommen, und irgendwann stand dann bei genau bei diesen beiden das Album mit dabei. Ist das nicht komisch?

Ich habe z.B. Hier (14.9 KB) ein Verzeichnis, da fehlt bei 2 von ca. 100 Liedern das Album, obwohl alles genau gleich ist. Bei anderen fehlt das Genre usw. <_<

Ich habe fleißig im Forum hier nachgelesen, aber nix... :book:
keine der Ratschläge hat geholfen.

Danke für die Hilfe!

Michael!

mp3tag.html (14.9 KB)


#2

Hallo Michael!

Vielleicht haben deine mp3s auch andere Tags, die leer sind, aber bevorzugt angezeigt werden?
Ein solches Problem wurde Hier bereits besprochen.

Gruß
nickless


#3

Hi!

Danke für die Antwort.

Nein, leider ist es das nicht. Dieses Thema habe ich schon durchgelesen, aber die Anweisungen helfen hierbei nicht.
Bei Id3-Tag wird auch nur WMA angezeigt. und wenn ich bei den spalten noch das read idtag hinzufüge kommt WMA(WMA), ist auch logisch...

Naja, bei anderen WMA funktioniert es auch, bei anderen wieder nicht.

Die WMA werden bei mir von einem Programm gespeichert, also sind die Angaben immer gleich! Warum funktioniert es dann bei einigen nicht? Das kapier ich nicht...

Bis dann, Michael


#4

Also:

Wenn ich im Windows Media Player bei einem Stück den sogenannten "Erweiterten Tag-Editor" bemühe und nichts verändere, sondern einfach nur wo rein klicke und dann auf ÜBERNEHMEN gehe, dann kann DANACH MP3Tag erst den kompletten Tag einlesen, warum auch immer.
Ich kann dies aber unmöglich für jeden Song einzeln machen!
Und wenn ich den erw.Tag-Editor für mehrere Dateien öffne, könnte ich nur ein und denselben Albumnamen für jede File eingeben. Das würde MP3Tag dann auch ohne Probleme einlesen, aber ich versteh nicht, warum das vorher nicht klappt. Jedenfalls muss man bei mehreren geöffneten Dateien das Feld anklicken (z.B. Album), sonst wird es nicht übernommen und das Problem besteht weiterhin. Aber wenn ich es anklicke, dann wird der Name des Albums des ersten Songs natürlich für alle übernommen, was aber nun mal nicht sein soll, denn ich habe verschiedene Titel auf einer CD, die nicht vomselben Album kommen.

Findet ihr eine Lösung? Bitte...

Sonst werde ich verrückt... :w00t:


#5

Hallo

Es könnte sein, dass die Tag in den betroffenen Dateien als Unicode (vom Mp3Tag nicht unterstützt :frowning: ) gespeichert sind, da muss man aber Florian fragen, vielleicht hat er eine Lösung dazu...

Gruß
nickless


#6

Wenn Du mir eine der betroffenen Dateien an meine Support E-Mail Adresse schickst, kann ich das Problem vielleicht identifizieren.

Viele Grüße,
~ Florian


#7

Du meinst doch eine WMA und nicht eine Tagliste oder? Ich schicke dir mal einen Song.

Übrigens seit ich einiges im Erweiterten Tag Editor des WMPlayers einfach übernommen habe, scheint es, als zeigt er "Genre" schon mal 100%ig an... Ist ja äußert verwirrend, aber wir werden das schon irgendwie hinkriegen. Mit dem Album klappt es leider immer noch nicht (was ja wichtiger wäre... :huh: )

Gruß Michael!


#8

"Hallo Michael,

danke für die Datei. Ich habe Dir hier
/MOD URL entfernt, da nicht für die Öffentlichkeit gedacht
eine neue Version bereitgestellt, mit der das Problem behoben sein sollte."

Hi Florian,

Danke für die neue Version. Spitzenmäßig, denn es funktioniert jetzt einwandfrei, soweit ich es bis jetzt gesehen habe. Ich denke du kannst nicht erklären woran es gelegen hat?! Auf jeden Fall super und dickes Lob.

Danke!!!

Lieben Gruß, Michael


#9

Hallo Michael,

es lag daran, dass ein anderer Tagger die WMA-Tags mit Bezeichnern in anderer Groß-/Kleinschreibung gespeichert hatte (WM/Albumtitle statt WM/AlbumTitle). Das entspricht so nicht dem Standard.

Mp3tag liest ab dem nächsten Development Build nun auch solche Tags und repariert sie beim erneuten Schreiben.

Viele Grüße,
~ Florian

P.S.: Das "nonpublic" in der URL zur Vorabversion hatte durchaus seine Berechtigung :slight_smile: