M3U playlists being created using ANSI instead of UTF-8

I'm trying to create a M3U playlist for an album, and the playlist winds up not working as the song filenames are in Japanese. The M3U is being encoded as ANSI instead of Unicode, and this results in Japanese characters being written as ??????.

Example:
10. ??????.flac

Is there way to change this? I'd rather not fix this manually, as there are plenty more albums I plan on creating playlists for.

Use M3U8 as the file extension for the playlist.

1 Like

Ah, thank you! This does in fact work, although with VLC it produces an error stating "VLC is unable to open the MRL", but the files play fine, and this error message goes away if the .m3u8 is renamed to become a .m3u file. Is there anyway to set .m3u8 as the default extension?

Yes, you can use .m3u8 as extension for the default playlist name at "Options > Playlist".

1 Like

Awesome, thank you so much!

1 Like