m4a genres not appearing in anything other than MP3TAG

Hi,

I've used MP3TAG to update about 17000 songs but just realized that the genre does not appear for any of my m4a files. I can see them in MP3TAG, but the category is empty (or something different) in xbmc, media monkey and itunes. Is there an easy fix to this?

Thanks!

If these programs have a database of their own you would have to use the function to update the database.
For iTunes you could use the "Information" function on a single track to force the update and see if the genre is actually there.
For updating the iTunes db there are a couple of scripts around - or you delete all the tracks from iTunes and reread them.
I do not know how to update the database (if there is one) for the other programs.

Unfortunately, I've tried that. I've clicked on 'Get Info' for a few songs in iTunes to no avail and have updated the library for other programs. (I know this has been done since other files like flac have been updated.)

I also have this problem. What appears to be happening is this: MP3Tag will read the ©gen tag (genre) in an AAC-style file (in my case, M4A). But when it writes the genre tag back out to the file, it stores it as Genre (I think it should be genre btw) and strips the ©gen tag out of the file metadata. The problem is other software isn't reading the Genre tags and so no genre shows up. It would be helpful if MP3Tag could write the ©gen tag instead (maybe as an option). I also note in the help page for "Tag field mappings" it suggests that for iTunes it uses "Genre" (which it does for writing) but MP3Tag will write eg ©ART and aART, not "Artist" and "Album Artist" as might be inferred from that page.

BTW MP3Tag is a great program and I am trying to use it as a "power" tool to fix my tagging that's how I came to investigate this.

scott s.
.

I have same problem for mp4 files, and not just with 'genre' but with 'album' also. These fields show a value within mp3tag, but Vista explorer shows the fields as blank, and my phone's Winamp app thinks they are blank too. An easy fix would be awesome.

(Source)

So it seems other software does not conform to the standard.

If you need a fix you can for example add a hyphen behind every genre so it is not a standard genre, like Rock-

Thanks. I've been playing around and now I'm not getting repeatable results, so I am going to have to reset and do more comprehensive tests. I should note my test files were created by ffmpeg 1.2.

scott s.
.