Mac: cannot write tags to file Filesize limit?

I'm constantly getting the error message "cannot write tags to file xxx" on a mac m1. It seems to be related to file size. i make my own audiobooks with m4btool and the size can go up to 2GB per file. i find that files < 1 GB can be written, but above i'll get this error.
is this intended behaviour?

I've just created one of those files, 1.82 GB in size, and tried to reproduce the issue. It works without problems, so it's not a general issue.

Are you performing the change on the internal SSD of your Mac or somewhere external?

i've tried on the internal ssd as well as an external (exfat one)
is there maybe a log of mp3tag with more descriptive errors?

Yes — you could also try and see if Console.app (set to streaming) produces any details on that error.

BackLog is another option, where you can set the process to Mp3tag and include all events that are not directly created by this binary.

i'm not really sure I understand you.

but i've opened the app in terminal with sudo and am getting this in the terminal

both the file as the folder's permission has been set to group "everyone"

with backlog i get this


), NSDestinationFilePath=/Users/ben/Desktop/s-6.m4b, NSFilePath=/Users/ben/Desktop/-6.m4b, NSUnderlyingError=0x1340dc5b0 {Error Domain=NSPOSIXErrorDomain Code=1 "Operation not permitted"}})

so it's really some permissions problems, which is weird as i was running mp3tag as root... and as owner of the file/directory...

Can you maybe extend the logging to Any Process in BackLog to see if there is some information from sandboxd or any other macOS service?

A post was split to a new topic: Cannot write tags to M4A files