(manjaro) files not showing from second hard drive

When I drag a audiobook to mp3tag nothing happens no info at all but then I tried my music files and they were fine they are on different hard drive, i need to make it reconize the drive with the audiobooks on it this worked fine before but i had to reinstall. I think this is hopefully just a matter of something beyond my scope at this moment...
The drive is ext4 I am sure this is the problem is there any way other than reformatting to fix this?

The general rule is: MP3tag uses the OS to access files.
Any files that the OS offers you and the accompanying access rights should be visible and writable.
Which also means that this is no MP3tag problem but an OS problem.

So should I move this to a different section than support?

I understood that the OS on which MP3tag runs does not support full access to the files on that external drive with ext4 partition.
MP3tag cannot be any better than the managing OS.
Or is this a Mac question?

No it is not mac related manjaro is arch linux based... it is running on wine though