Mappings of vorbisComments DATE, TRACKNUMBER

Hello and thank you for having a look at this,

I routinely batch transcode FLAC files to mp3, and most of the time the resulting files are missing the year or track number, or the year is different than the corresponding field in the source files.
At first I thought there was an issue with the transcoding software, and got in touch with the developer.
He eventually noticed that the issue is how MP3tag writes FLAC metadata, apparently in a non-standard way for both fields:

  • year to year instead of date
  • track number to track instead of tracknumber

I see in MP3tag preferences that if I check use field mappings, I can remap fields and that both year and date are remapped to the standard fields by default.
I suppose checking that option will solve my issue, but this remains perplexing: why would mp3tag not follow standard practices by default ? Are there disadvantages ? Or have I disabled this myself unwittingly ?

Thanks !
Nicolas

I've just checked with a fresh install and the field mappings are enabled by default.

Ok, thank you, this is unexpected but certainly possible.

More on this here at Preferences → Tag Types → Use field mappings:

Mp3tag comes with a list of pre-defined default mappings for VorbisComments. It’s generally recommended to not remove those to preserve interoperability.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.