MMJB "Various Artists" fix


#1

I am a new user of MP3Tag. Very nice. Google search with "mp3tag" as a key word helped a lot in finding out how to get started. Eventually found the FAQ and HELP which helped even more.

One data type problem I has was cleaning up after MusicMatch Juke Box ripping of a compilation disk.

The problem is that MMJB tags compilation tracks as follows:

Artist="Various Artists"

Featured Artist=artist / ...
eg: "Bill Anderson / Jan Howard"

Comment="MusicMatch_TrackArtist: "artist / ...
eg: "MusicMatch_TrackArtist: Bill Anderson / Jan Howard"

The Featured Artist tag is not supported by MP3Tag but Comment is.

The solution I eventually worked out was to create a new 3 step action.

  1. Format Value:
    Field: ARTIST
    Format string: %comment%

2)Replace:
Field: ARTIST
Original: MusicMatch_TrackArtist:
Replace with:

Note: Trailing space on Original string.

3)Replace:
Field: ARTIST
Original: /
Replace with: &

Select All files in directory (Ctrl-A). Apply Action. Visually inspect results and if it look good then Convert tag -> filename to finish cleanup (I use %artist% - %title%).

Not fancy but I was still figuring out how to use RegExp and Scripting Functions with MP3Tag when I implemented the fix.

Thanks for the handy tool. Made a massive cleanup job much easier.


#2

"Featured Artist" might be supported. Just fire up the :mt_tag: Tags window (ALT+T) and look at the name of the field.


#3

Nope. And after a bit more research I have found the reason.

MMJB arbritarily extends the ID3 tags by using custom tags encoded in Comments.

ie. There is no "Featured Artist" tag or use of any of the other extended ID3v2 tags. Just the info buried in the comments.

The full format for MMJB comments seems to be:

["MusicMatch_"://]...

I have used MMJB+ as my default ripper for years (bought a lifetime update back at version 4) but recent releases have been very buggy. I was manually fixing the compilations but MP3Tag cleaned up the process very nicely.

Definite keeper app. Donation on the way.


#4

MMJB saves most of its extended tag infos in multiple comment fields, distinguished by different descriptions.
The simplified structure of a comment frame looks like this:

MusicMatch_TrackArtist for example is a description

The problem is that Mp3tag does not really support the description ATM.
In v2.35 it shows the description, but when the file is saved, the description is moved to

In the latest version the description is not displayed anymore, and when saving the tag it gets deleted.

Both versions will probably make MMJB not recognize the comment infos anymore.


#5

This has been changed with the latest Development Build. Editing MM fields should be much easier now :slight_smile:


#6

Thanks. I will give this a try. I held off on testing 2.35e after seeing some of the problem reports. I had no specific need of ID3v2.4 and needed to get a new library cleanup done.

Will make sure to test MMJB bi-directional comment editing.


#7

Finally got around to testing this feature.

Used:
MP3Tag 2.35K
MMJB Plus 10.00.4033

Test:
Copied an MP3 to test directory as test\test.mp3

In MMJB:
Opened test.mp3
Edit Track Info
Create new tag info
-Featured Artist
-Tempo
-Mood
Apply change

In MP3Tag:
Ctrl-D to test
Select test.mp3
Check Info with Ctrl-Q
Check Info with Alt-T
In Alt-T:
-Modify Featured Artist data
-Save Change

In MMJB:
Recheck with Edit Track Info
ALL comment tag info gone. Not even showing up as Notes.
Re-edit feat artist

In MP3Tag:
Alt-T shows just the single FA comment

Conclusion:
Support for multiple comments and comment descriptions appears to be limited to use in MP3Tag. Any edits in MP3Tag causes ALL comment data to be lost to MMJB.

Not a big problem to me as I don't use these extended tags, but, could be a problem to other MMJB + MP3Tag users.

Main reasons I continue to use MMJB are support for MP3Pro, very good librarian, and high speed ripping. Main reason I am switching away from it is bugs and reliability problems in recent releases.


#8

Maybe MMJB doesn't support Unicode or ID3v2.4 (depends on your settings at Options > Tags > Mpeg)? Since Mp3tag still displays the comment fields, they are saved correctly.

You can try to enable the ISO-8859-1 option, but I won't install this app to test compatibility.

Best regards,
~ Florian


#9

The ID3V2.3 ISO-8859-1 write tag option made the tags bi-directionally editable.

However the original Various Artist compilation fix procedure no longer works at all.

%comment% now only shows contents of an undescribed comment tag.

i.e.
"COMMENT = sometext" tag results in %comment%="sometext"

and any

"COMMENT description = moretext" tags are ignored.

This is a change in behavior since 2.35(stable). Previously Ctrl-Q and File View was showing %comment%="description: value//description2: value2//".

I also tested %comment% in Convert: Tag -> Filename preview. Same result.

Edited: To correct info about last working version.


#10

That's how it works now.

Use %COMMENT MUSICMATCH_TRACKARTIST% to get the TrackArtist.

The way the tags appear under View > Tags... and adding % around them is how you can access them.


#11

Thanks Dano. That worked.


#12

Dano. Another Question.

I was able to add a new column to File View:

Name: Feature Artist
Value: %COMMENT MUSICMATCH_TRACKARTIST%
Field: %COMMENT MUSICMATCH_TRACKARTIST%

Worked just fine. Without Field the tag was write protected as expected. With Field the correct comment tag was edited.

Now, how do I < blank > or remove just this tag?

Ctrl-Q only works on %COMMENT% (which is fine).

Can't seem to find an appropriate action. :unsure:


#13

You can press ALT+T and remove it.
You could add a new field COMMENT MUSICMATCH_TRACKARTIST to the tag panel in the options.
Or just write an empty value in the column
Or use the action Remove fileds with COMMENT MUSICMATCH_TRACKARTIST


#14

Nice.

The Option -> Tag Panel did not work the first time I tested it because I did not have a track selected with the special tag. Worked a treat once I selected a MM tagged track. removed the tag.

The action works as well.

Thanks again.