Move PROD BY to Composer not working anymore!

I have a lot of songs with "Prod. By XXXXXXX" at the end of the title. With the help of this forum, I had a script that would move the producer to the composer field. However, the script recently stopped working! No changes were made! Now it copies the entire song title to the composer field instead of just the producer's info.

This is the best way I knew to show you what my script is:

[#0]
T=5
F=HOMER11_SWAP
1=%TITLE%

[#1]
T=4
F=TITLE
1=^(.) (\\(.\\))$
2=$1
3=0

[#2]
T=4
F=HOMER11_SWAP
1=^(.) (\\(.\\))$
2=$2
3=0

[#3]
T=5
F=COMPOSER
1=%COMPOSER% %HOMER11_SWAP%

[#4]
T=9
F=HOMER11_SWAP

[#5]
T=4
F=COMPOSER
1=\\([p|P]rod.* [b|B]y
2=
3=0

[#6]
T=2
F=COMPOSER
1=)
2=
3=0|0

Any suggestions? HELP!

Assuming this group of action has been working without any error in the meantime and assuming that you have nothing changed on this group of actions, then your newly problem has nothing to do with these actions.

You should search for the problem at another place in your workflow.

At first I would look at the TITLE content of your incoming tracks, do they match the criteria to be treated by this action group? If not so, then this action group might give an irritating result.
You should simply create a new fitting action to react to the new case.

DD.20100110.0943.CET

If I understand you well ... see following steps ...

  1. Set Mp3tag/View/Filter:
    TITLE MATCHES "^(?i)(.+)\s+prod.\s+by\s+(.+)$"

  2. Run Action "Format value":
    Field: COMPOSER
    Value: $regexp(%TITLE%,'^(?i)(.+)\s+prod.\s+by\s+(.+)$',$2)

From TITLE:
Daydreamer Prod. By XXXXXXX
To COMPOSER:
XXXXXXX

  1. Run Action "Format value":
    Field: TITLE
    $regexp(%TITLE%,'^(?i)(.+)\s+prod.\s+by\s+(.+)$',$1)

From TITLE:
Daydreamer Prod. By XXXXXXX
To TITLE:
Daydreamer

Good luck!

DD.20100110.2140.CET