Moving multiple files under Wine on macOS fails

I am running MP3Tag on wine on a macbook pro 2.4 ghz, 8gig ram running high sierra 10.13.2. The program works flawlessly including playing files through vlc. The only function that does not work is moving multiple files. Moving one file works, but when multiple files are selected nothing happens. No error, no message. I am using wine version 2.04. Any help on this issue will be appreciated.

Please tell us how you move the files. There are so many options.

I highlight the files of interest and then go to Edit/Move and select the destination. A dialog box shows up indicating the content for the directory may have changed if I want to reread the current directory. Wether i press yes or no the files are not moved. When I select one single file and go to Edit/Move and select the destination, the file is moved right away. No dialog box shows up asking for a refresh.

I just tried it with an ordinary Windows and did not get a message box to reread the folder but on the other hand all the files I tried to move (a single one and many more) got moved to the destination folder.
So, sorry, I can't help you as apparently under Windows it works as intended.

I've confirmed the issue and think that it's caused by a bug in Wine. I've filed a bug report and we'll see what someone with more knowledge of the Wine codebase has to say.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.