MP3Tag doesn't remember installation path

Can you please make the installer remember or detect where the older installation path is?
I don't usually install my software into Program Files so every time I update the beta I've to manually change the path, it's not something critical but would be nice if you change it.
Thanks.

I think that this is always the case for standard installations.
If you select "Portable installation", nothing is set in the registry, so MP3tag does not see any previous installation.
If you had a portable installation before, you can easily install a standard installation over the one in the folder of the portable one. You only have to set it once.

1 Like

That's weird, I've always installed MP3Tag, I've never used the portable version and the installer has always never detected where it's installed and simply gives me the default installation path which I have to change to C:\Software\MP3Tag. This is not something that is happening just now, it has always happened iirc, just I haven't got the courage to request something as trivial as this problem. Will try in another machine.

OK, so I tried on another computer and it's working well in there, MP3Tag remembers the path of previous installation, but in my main computer it doesn't. I've tried uninstalling it and reinstalling the release version and then updating it to beta to see if it will remember the path but no. The installer always point to the default installation path. I checked in the registry and InstDir is pointing to my path so I don't know why the installer ignores it.

I've thought about this but cannot make sense of it. How do the two systems differ from each other (e.g., Windows version, user account rights, ...)

The only difference is that my main computer (where I have the problem) has UAC disabled. Apart from that is the same basically. Same OS version, both accounts are admins, both computers I tried the same procedure (first install release version then update to beta).

Which version of Windows are you using?

Right now it's Windows 10 Pro 1803, in both machines.

I know this is an old thread, but I too have recently realized the same issue. I am using the standard version of the x64 install (v3.17). I have uninstalled the previous version and did a fresh install of v3.16 and then tried to update to v3.17, and it didn't remember the previous installation path and I had to enter it manually.

The only other thing I did besides an install was restore the configuration by unzipping to the Mp3tag roaming folder. I did delete this folder manually after uninstalling.

My installation path is on another drive (e:).
Windows 10 Pro, version 21H1.

Thanks
Greg

Yes, I have seen this also.
I suspect that this is due to the new path for programs in 64 bit.
I changed the target path manually, still I agree that it is annoying.

Thanks for pointing! As @ohrenkino suspected, it's related to support of 64-bit, where basically two views on the Windows registry exist and the installer currently reads from one but writes to the other wrt. the installation path.

I've just made a silent update (the Mp3tag.exe is unchanged) which should fix this installation issue.

Yep, that worked - it used the (non-standard) folder of my previous installation.

1 Like

So I wasn't crazy after all

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.