mp3tag screws VBRs up

Ok what I did in short form:

  1. Encoded an mp3 with LAME and VBR
  2. Put it on my mp3 player (File 1)
  3. Edited its tags with mp3tag 2.43
  4. Put it on my mp3 player again (File 2)

What I got:

  • No problems with file one. It will play and I even can fast-forward and rewind it (however that works with an vbr) and the player shows the average bitrate.
  • File two will be played as well. However the ffw and rew features are crippled: I can jump only in blocks and the player shows ridiculously high bitrates (above 320kbit/s mostly something around 1700-2100)

I believe that LAME safes additional data about the file and the encoding process in the tags or somewhere and mp3tag erases these data. Is there anything I can do about it? I would like to use mp3tag for it's the best tag editor on the web but I also want to use VBR for it has the best quality-size-ratio.

My player is an Archos Gmini XS202s btw. But I don't think that this matters. And yes I used the board search and came up with a similar topic but there was no solution.

Thanks in advance for your help!

Not sure what your problem is with the file and/or player, but I have thousands of mp3 files that are VBR and I've used mp3tag on all of these with no problems. So the issue is not mp3tag and vbr. Perhaps it is something about the player. Also, are you sure you are writing only the type of tags with mp3tag that your player expects to see. That is, when you save files in mp3tag, it can be writing various types of tags depending on what you've selected in the options.

I have to disagree. Maybe your player uses different methods to calculate the exact length of your VBRs but mp3tag definetly does something with them. I double checked it now:

  • File 1: the file created by LAME
  • File 2: took file 1 and edited a tag with mp3tag
  • File 3: took file 2 and edited a tag with foobar2000 (0.9.6.8)
  • File 4: took file 1 and edited a tag with foobar2000

File 1,3,4 are played without problems, file 2 shows the problems described above.

Please try /t/2785/1

Dano your my god! Problem solved. Thx a lot.