Nach Speichern kommt alter Tag zurück


#1

Hallo Florian,

ich habe etwas komisches gefunden, bin mir aber nicht sicher, ob es ein Bug oder "normal" ist.
Ich habe eine MP3-Datei mit folgendem ENDE:
4C 59 52 49 43 53 42 45 47 49 4E 45 41 4C 30 30 ; LYRICSBEGINEAL00
30 30 33 53 26 4D 45 41 52 30 30 30 30 39 4D 65 ; 003S&MEAR00009Me
74 61 6C 6C 69 63 61 45 54 54 30 30 30 33 32 30 ; tallicaETT000320
31 2D 4D 65 74 61 6C 6C 69 63 61 2D 54 68 65 20 ; 1-Metallica-The
45 63 73 74 61 73 79 20 4F 66 20 47 6F 6C 64 30 ; Ecstasy Of Gold0
30 30 30 37 39 4C 59 52 49 43 53 32 30 30 54 41 ; 00079LYRICS200TA
47 30 31 2D 4D 65 74 61 6C 6C 69 63 61 2D 54 68 ; G01-Metallica-Th
65 20 45 63 73 74 61 73 79 20 4F 66 20 47 6F 4D ; e Ecstasy Of GoM
65 74 61 6C 6C 69 63 61 00 00 00 00 00 00 00 00 ; etallica........
00 00 00 00 00 00 00 00 00 00 00 00 00 53 26 4D ; .............S&M
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ; ................
00 00 00 00 00 00 00 00 00 00 00 31 39 39 39 39 ; ...........19999
32 30 66 62 33 30 62 00 00 00 00 00 00 00 00 00 ; 20fb30b.........
00 00 00 00 00 00 00 00 00 00 00 00 01 11 ; ..............

Jetzt ändere ich auf welche Weise auch immer (Direkteingabe oder Editfelder-Eingabe) beliebige Daten und speichere diese. Alles scheint perfekt. Wenn ich aber jetzt MEHRERE Dateien markiere und z.B. den Kommentar für alle Dateien neu festlege, stehen nach dem Speichern plötzlich wieder die ursprünglichen Tags in der Datei. Alle Änderungen scheinen weg zu sein.

Kannst Du das auch nachvollziehen?
Brauchst Du noch mehr Infos?

Ciao,
Siegmund


#2

Hallo Siegmund,

ich hab Dir eben einen URL geschickt zu einer aktualisierten Version.

Ich würde mich freuen, wenn Du versuchen könntest, den Fehler mit dieser Version nochmal zu reproduzieren.

Falls der Fehler immer noch auftritt, wäre es denke ich am Besten Du schickst mir die Datei.

Viele Grüße,
~ Florian


#3

Hallo Florian,
ich werde die neue Version ausprobieren!
Ich brauche Dir denke ich nicht die ganze Datei senden. Ich habe es auch reproduzieren können, indem ich den ID3V1-Abschnitt durch den obenstehenden ersetzt habe. Dadurch habe ich jede Datei so hinbekommen, daß er Fehler auftrat. Frag mich jetzt bitte nicht, ob das ganz ok ist oder ich das MP3 dadurch zerfetze :o

Wenn der Fehler mit der neuen Version noch immer auftreten sollte, sende ich Dir gerne mal die Datei rüber.

Ciao
Siegmund


#4

Hallo Florian,
ich habe heute mal die Version 2.02e für Jörg ausprobiert und der Fehler ist da noch drinnen. In der Version, für die Du mir den Link geschickt hast ist der Fehler BEREINIGT !

Ich habe ihn nicht mehr reproduzieren können!
Was war denn das Problem?

Super jedenfalls und Danke ! für die prompte Bereinigung.
Ciao,
Siegmund


#5

Hallo Siegmund,

danke für Dein Feedback und für die Fehlermeldung!

Es lag daran, dass der Lyrics-Tag (ist ne andere Art und Weise Informationen in MP3s zu speichern) unter gewissen Umständen beim Speichern mit beachtet wurde. Die wiederkehrenden Informationen waren also aus dem Lyrics-Tag.

Viele Grüße,
~ Florian


#6

Hallo,

erst mal -> Tolles Tool!!
:slight_smile:
Der Beitrag entspricht in etwa meinem Problem.
Beim Abspeichern einer ganzen Liste mit Änderungen werden einige Felder gelöscht und andere bekommen ihren alten Inhalt wieder. Wenn ich die Felder einzeln ändere und speichere funktioniert es aber.
Die MP3's habe ich mit Feurio gemacht - allerdings habe ich den Haken aus dem Lyrics-Feld nicht entfernt!

Ich verwende 2.02d.

Gruss
Martin


#7

Hallo Martin,

die neue Version kommt noch diesen Monat! In der wird der Fehler dann behoben sein.

Viele Grüße,
~ Florian