New and unusual issue with Windows Explorer right click

Used to be that if I highlighted all files in a Windows Explorer folder and right-clicked to "Mp3tag" the music files among them would all load into Mp3tag. In past day or so this no longer works. I can successfully right-click load a folder or a single music file, but when I highlight a range of more than one file then Mp3tag does not open.

Confirmed that things work as expected on a second PC but no longer work on this one. How can I fix this? OS on both PCs is Windows 7 x64. Thanks.

It seems to be working fine on my Win7 machine. I remember the behavior you are experiencing in early versions of Mp3Tag. What version are you running?

I see you joined three days before I did back in 2004.

Hi, I'm using 2.78 on both machines. Tried copying over the .CFG file from the good PC to the bad but no luck. Thinking I may have a corrupt context handler but how could that happen? It's late here but in the morning I'll try copying over the good .DLL and see if that fixes the issue.

Yes, I'm an old timer!

First thing you should try is to reinstall MP3Tag, which is done in 10 seconds.

It was the first thing I tried. I have also copied over the good .DLL and the registry values for this context handler all with no success.

You can add the version to your profile to display under your avatar as I have done so no one has to ask if you are current. TIA for adding it. Few go so far as to change it with 2.78b as Poster has done.

I would assume that there is some access collision.
E.g. the one PC runs the indexer, the other does not.
Or one has the setting to create thumbnails, the other has not.
Here it would be nice to have a little investigation if any new programs have been installed that may be interested in the music files.

Also, it could be that the access rights are not OK esp. with the copying between PCs. Check the owners of the corresponding folders. They should be the same as the ones that use MP3tag.

Thanks for all the suggestions. I tried updating to 2.78b with no luck. I then uninstalled Mp3tag, deleted all folders including APPDATA, deleted all references to the program from the registry, rebooted and did a full install of 2.78. The problem is still there.

I understand the idea of a "collision" in the process handlers but I don't recall anything I've installed recently that could affect this. Is there a way to get a report of what is happening during the "crash"?

Not that I know of.
I would still compare settings on the 2 PCs: where is the difference?

Happy to report this problem went away. Windows Update, reboot, I don't know what; things work as expected again. Thanks for all suggestions.