No .csv after exporting as a csv file

I exported some files in csv format and noticed that there is no extension .csv after the file name MP3TAG. The correct file name should be MP3TAG.CSV, consequently it cannot be opened in the correct way to import the data into Excel. My question is why?

You would have to show us the export script and the settings that you use in the Export dialogue.

I doubt that excel cannot open such a file if you first open Excel and then open the file with Excel functions.

Fascinatingly, the dump that you show, displays the file "mp3tag" with the green X that I think comes from Excel - so apparently Excel is already set to open that file.

Here is the script I used:

$loopend()build on %_date% with %_app% - the universal Tag editor - Mp3tag - the universal Tag Editor (ID3v2, MP4, OGG, FLAC, ...)

no changes other than the formula you gave me for minutes and seconds and needless to say the arrangement of headers.

As the script does not specify a particular filename, please note the documentation:

Also, could it be that you have set the explorer to hide extension of known files?

I forgot to mention that you cannot open a csv file directly into Excel, as you well know. You must open the csv file by going to File>Open>Browse>Folder name>All Files.
I found that if you Rename the file to MP3TAG.CSV, Excel will give you the dialog you need to bring the data into Excel correctly but you shouldn't have to do that because it should already have the .csv extension.

Quoting from the documentation: $filename(name,enc) Optional statement that sets the file name, file extension, and/or encoding of the exported file. Needs to appear at the beginning of the export configuration. The optional second parameter sets the encoding of the export file. Possible values are ansi, utf-8, and utf-16.

If you note that the string starts as $filename(csv,utf-16) which should tell the file what it should be and it's not.

The documentation also says:
"The default file name and/or file extension can be set from the export configuration (see $filename() below). Otherwise the previously used file name is prefilled. The file name to be used can always be adjusted upon export when the export dialog is shown."
So: please show us the Export dialogue Ctrl+E and which filename you have defined there.

In the Export config window that opens, you need to include the .csv extension on whatever filename you define. When you first select the export type, it will include a default name like "New export file.csv" that you can of course change, but still requires the extension there.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.