Not enough memory / Runtime error

Right clicking my music collection folder in order to open it in Mp3tag,
Results in reading directory... until I get this error message:
https://gyazo.com/73bfaeb02c689001b0db928cfbbf96ec

When clicking ok, I get the following message:
https://gyazo.com/9fc80c416b5e902c52f1d79af522a54e

Reading this topic, [F] Not enough memory addressable to complete the operation!, I've made sure to test my FLAC files with AudioTester64 and re-rippped/downloaded the ones that were either Truncated, LostSync & CRCMismatched (and deleted these faulty ones).

Since that didn't do the trick yet, I've used MP3 Diags, using option 4 where it does the following:
https://gyazo.com/1634cd70f3aa142d36fc1a14914e7fb4

Attached is the log-file.
Mp3tagError.log (404.6 KB)

I mean, 12000+ files, shouldnt be an issue with Mp3tag, nor my PC specs: AMD Ryzen 1700x / 32GB DDR4 RAM
OS: Win10 x64 1709
Mp3tag: v2.87a

MP3tag is a 32bit application, so (only) 4GB or memory are available.

Check if you run into the same error when you switch on the library (see Tools>Options>Library). This feature releaves the electrical storage as it puts a lot of information on the hdd.

I don't know if MP3diags is the right tool for flacs ...

Thanks for testing all the different error causes before posting.

Can you somehow reproduce the error? Does it always happen with a specific file?

If so, it could be that this file causes Mp3tag to try to allocate too much memory which would also result in the out of memory error (some kind of attempted memory exploit).

If you could identify the file that causes the issue, it would be great if you can provide it for analyzing purposes.

I use MP3 and FLAC files in my music collection, hence the 2 apps I mentioned.
AudioTester64 for FLAC (only) failure detection (no way to fix them, but replace them with valid files);
MP3 Diags for MP3 (only) - to fix bad tags and more.

Meanwhile I set the path using Tools>Options>Library and it seems to make a difference, see:
https://gyazo.com/3c8a1abd4e6fba00f630197c0b35443d

Not sure how to go from here though...

How do I know it happens with a specific file?
I mean, when opening my subfolders 1-by-1 in Mp3tag, I dont have this issue.

See my structure/subfolders:
https://gyazo.com/d0a131a7a2b134b2a37b1bd364551c30

I managed to open up all folders in 1 go (9777 files) without issues, like this:
https://gyazo.com/cde4a55be70e898fc45a8d9b200796b9

Mind you, the House folder which I've deselected here, is the biggest (92GB - 2912 files).

When I select them all, I get a different error-msg by now, see:
https://gyazo.com/54c0b819c22fc3a115316b6f9cf18de7

Seems it's not related to the House folder though.
Here I open up all folders in 1 go incl. House folder (total of 9665 files), without issues.
https://gyazo.com/5d18b81572f644407dbd0c2bbb2011fd

Leaving Hardcore folder, since that's another huge one by itself (75GB - 3024 files).

Hmmm.

I've used the Convert action Filename - Tag on all folders by now, which all seem to do fine.
If I grab more than 5000+ in 1 batch, I get the same ''not enough memory'' error message.
This means, it's not related to a specfic file, right?

I load more than 100,000 files in one go (mp3 ones, very few flacs, though) without any problems.
So I would still check

  • the HD integrity with chkdsk /r /v
  • see if the HD has problems in general with crystaldiskinfo.
    Then I would load different subsets of files to narrow down what may be the cause.

After doing a chkdsk /r /v on my C: drive - where Mp3tag is installed - 512GB SSD, waited 50 minutes & finished.
I did the same for E: drive where my audio collection is (2,20TB - 5900RPM): waited 4 hours and still at 14%.
Pushed the Reset-button.
CrystalDiskInfo shows SMART of both drives: GOOD with temps around 35 celcius.

I also have dBPoweramp which is able to do a Filename - Tag in Batch-mode.
Let's see how that works out.

dBpoweramp worked out fine, no issues.
Though that's 64-bit app.

A friend of mine, suggested https://docs.microsoft.com/en-us/sysinternals/downloads/procmon to keep track where mp3tag gets into error-mode, to trace on which file.
Let's find out.

Not sure, if this helps but capture 1 is with the last succeeded FLAC file here:
https://gyazo.com/9d03c77a5d64f05b52b17bdf3e3c51ce

And capture 2 is with the last message of Process Monitor filtered on Mp3tag.exe:
https://gyazo.com/e7b64831c03d4f8f688e7fc64898d8f7

Does this help?

Deleted the Rod Stewart song, just to be sure, it's not simply that song.
Now it's Jimi Hendrix where it stalls (though shows SUCCESS), so not sure this error is actually file-wise:
https://gyazo.com/344b5bf57a851fec51bdb802fda3c3f1

The same friend suggested to look up the mem-usage of Mp3tag.
According to him due there is no 'large address aware' switch for Mp3tag it only uses 2GB max.

TECHNICAL FILE INFORMATION :
File Type Description : Portable Executable (PE)
Entry Point RVA: 003548C1h
Entry Point RAW: 00353CC1h

FILE CHARACTERISTICS :
Relocation info stripped from file
File is executable (i.e. no unresolved external references)
Machine based on 32-bit-word architecture
FILE HEADER :

Machine:                          014Ch (i386 or later, and compatible)
Number of Sections:               0004h
Time Date Stamp:                  5ABD46AFh  -> 29/03/2018  22:03:59  
Symbols Pointer:                  00000000h
Number Of Symbols:                00000000h
Size Of Optional Header:          00E0h
Flags:                            0103h

So I enabled the /3gb switch according to this tutorial and rebooted:

Still same issue, as shown here:
https://gyazo.com/f6288e65decb7d7b3bcbbcd68f1da0f4

Mind you, before the /3gb it was stalled at 1.815,6MB of Memory usage (so practically the same).

''If a 32bit executable does not have the LARGEADDRESSAWARE flag set to true, the application can't use more than 2 gigabytes. If you are on a 64bit machine with lots of memory, even if you are stuck with a 32bit process, you should ideally be able to start multiple processes each using 3+ gigabytes.''

I do not think that 4 hours for just 2 TB is normal.
And as the process did not finish, it is hard to say what the cause may be as faults on the drive, which I suspect, have still not been ruled out.

Copied the whole collection over to external drive, tried mp3tag on different PC (i5 3470 / 16GB) ; same result. Not enough memory:
https://gyazo.com/690e5632e818c0becd8767647cae17e7

Doesnt this outrule a faulty drive?

Yes, I would say so.
But again: I can load FAR more than just 5000 files into MP3tag.
So the assumption is not too far-fetched that it has to be some kind of local condition that causes it.
If the fault is still there when the collection is treated on a different hardware, we are more or less back to square one: it is most likely that one of the files has a fault.
And all this happens with the library switched on?

Just tried it on the i5 PC, this time with Library set to Ext. drive/Music folder, same result.
I will now make a copy of the whole music collection folder (327GB).
And delete the FLAC files; so MP3 is left over.
And do the same on the copy, but then delete the MP3 files; so FLAC is left over.
So the folder structure stays intact.
Re-import only MP3 based collection and re-import only FLAC based collection.
To be continued.

Hey All, I'm the friend of Bas... mp3tag ran out of memory at 2GB, so i edited the binary to support the larger address space (4GB). (editbin /LARGEADDRESSAWARE ).

Now we can load more mp3 and flac and it runs out of memory at 4GB.. My conclusion: recompile mp3tag witg 64bit support.