Numbering Wizard does not order tracks

Hi, sorry for probably being a complete noob but my Cowon J3 arrived today and I am transferring some of my lossless files over. I used to use Itunes and played ALAC files but I have converted them all into WMA lossless through dbpoweramp. Now Itunes ordered my songs fine on my Ipod. When I converted them into WMA lossless and put them on the J3, it was hell. Nothing was organized. So I downloaded MP3 Tag and was told to use the auto numbering wizard to order track numbers per album, and I did....and it's not working for half of them.

Some albums worked fine but others are not doing so well. An example I have of an unorganized album is Blackwater Park by Opeth. I have th CD and the DVD tracks on the same album (I like hearing the two different mixes, so there are 17 songs instead of the 9 originally. 9 songs on the CD (one of them is a live track) and the first 8 on the DVD again. When I try to organize all 17 songs, it still shows up as out of order on my J3....but when I only place the first 8-9 songs on my J3, it IS in order.

What am I doing wrong? I made sure everything was exact per track, same spelling for artist, deleted disc number and composer, etc.. I don't understand why I can't place the DVD-A tracks without being in order.

Have you filled the ALBUMARTIST tag?

Just tried it out.

Doesn't do anything.

Just to get it clear: you have arranged the tracks so that there are the first 9 tracks from the CD and then the other tracks from the DVD and you have numbered them sequentially so that the track numbers of the DVD tracks do not start with 1 but with 10, right?
also, it could be that your player does not look at the track numbers but only at the filenames - use the converter tag - filename with a mask like
$num(%track%,3) - %title%
to rename the files

Yes, the DVD tracks are listed from 10-17, they always have been.

Ok so here is exactly what I did:

-highlighted all 17 tracks (they appear on order in Mp3 Tag)
-clicked convert
-clicked tag - filename
-pasted "$num(%track%,3) - %title%" into bar
-clicked ok, then pasted the album onto my Cowon J3

No change at all. I should mention that all of the tracks are listed like 001 to 017, not that a difference was made.

Yes, the $num(...,3) creates 3-digit-numbers with leading zeros...
Sorry, that I have to ask again: the filenames of the tracks now consist only of the number 001 to 017 and nothing behind the hyphen
or is the actual title behind them like
015 - Best song I ever wrote
?
(The reason why I am asking all this stuff: I am trying to find out which sort criteria is used by your player - this could be the filename or actually tags. And if it uses tags - are these tags filled? Because if they are not, then all the files look the same an my get sorted by a randomizer (= not at all))

They are displayed like "001- Track name" not just the numbers.

Sorry to have wasted your time - I can't help you any further.

OKAY, I've discovered part of the problem.

If an album has more than 9 tracks, it will be out of order.

Example: Gloria by Disillusion has 11 songs. After using numbering wizard and placing it on my Cowon, the order of the tracks is as follows:

1
10
11
2
3
4
5
6
7
8
9

For some reason I don't know how to make sure any digit beginning with "1" goes in its proper place. I'm pretty sure tracks 10 and 11 appear near the top instead of near the bottom because they begin with the digit "1", basically.

So, how do I solve this?

wma track numbers are problematic because there are several ways to save them internally in the file.
It seems the way Mp3tag does it is not compatible with your device.

You should have a look at your cd ripper dbpoweramp, it has an option to change the way the track numbers are stored.
See this thread for more help.

This does not solve the basic problem but will get your tracks in a sequential order:
Use the numbering assistant but start with a two-digit number if the album has more than 9 tracks, e.g. 10.
So, e.g. the first track becomes 10, the second 11 and the 12th becomes 21.
This should put it in the right order - but does not reflect the original numbering.

FLAC albums seem to work fine on my Cowon, so I'm just converting all my WMA lossless tracks into FLAC.