Part of column name in tag

Hi!

First of all, thanks for a great program - I am using it to make playlists
for a countryband here in Sweden :slight_smile:

I have one strange behavior of Mp3Tag however.....or maybe its just me not
fully understanding the program....

I have made some custom tags/columns named "Lead" (%lead%) and "Variant" (%variant%)
and filled them with some information that show up in columns. But sometimes there is a change
so the info is changed to "ead" and "ariant" instead!? The column names stay right, no change there.

Have I found a bug - or maybe its something I doing wrong?

Enter %lead% and %variant% in the fields option of the column setup only and not the values.

Do you mean in Customize Columns dialog??
If I do that all the data I have entered in columns is disapeared.
And I cant write in new data by doubleclicking cell...

Its strange that my error only appear i some of the cells.

Yes.

Create a separate column for each:
One example:
Name: Lead
Field: %lead%
Value: %lead%

Its not a good idea to have two fields in the one column.

:slight_smile: Thats exact what I did in the beginning :slight_smile:

But strangly some of the values is overwritten by part of the columnname.

I make a gif-animation to show what I mean...(hope it works):


Aaah! - the customize columns-dialog didnt fit in gif....sorry, but the values-values and field-values are exactly like you told me :slight_smile:


Doing that at the beginning has lead your tags to take on those values. I tried the same thing at the beginning but only on a handful of dummy mp3 files I have for tasks like that. A regexp should fix your problem.

For the %lead% use the replace with regular expression:
Field: LEAD
regexp: ^(?-i)ead$
replace with: leave this blank

^ anchors to start of text string
(?-i) matches remainder of regexp with case sensitivity
ead matches 'ead'
$ anchors to the end of text string.

This will only remove that field with the values 'ead' and nothing else. Not even 'Ead'.

For the 'ariant' problem do similar to above with:
Field: VARIENT
regexp: ^(?-i)ariant$
replace with: leave this blank

PS: It's okay to display two fields in a column as long as you intend not to edit them and you don't fill in the value part.

I have a cover art columns which displays, how many covers, its size in kb and the format like so:

$ifgreater(%_cover_size%,0,%_covers% | $num($fmtnum($div(%_cover_size%,1024)),3) | $regexp(%_cover_mimetype%,'.*/([^/]+)$','$1'),'-')

see attached:



But...I am totally lost.....they were empty in the beginning!? I filled the empty tagfields with the names (Per, Kent etc. by clicking in tagfild and write) and at some point only some of them were changed to "ead" (by there self after restart of program!). At that point I clicked the field and changed them back, but now the "ead"s are back, and only on some of the tagfields in column.

Voaw!!! :slight_smile: My oh my! :slight_smile: Never used regexp before, but some time will be the first :slight_smile:
I´ll try it! Thanks! But how do I get the values of tags back?? The "ead"s and other has written over my values I filled in before the change, and it happens now and then.

I am not sure if I understand you correct - are you saying I am using two fields?? Because I want to be able to edit them (and get the changes stay:-))

Regards
Thomas

Yes, it seams when you place two fields in the value part (you can in the fields as long as you don't put anything in the values part) it will behave like this and permanently mess up your tags. My screenshot is a bit misleading. $ifgreater(%_cover_size%,0,%_covers% | $num($fmtnum($div(%_cover_size%,1024)),3) | $regexp(%_cover_mimetype%,'.*/([^/]+)$','$1'),'-') should be in the field section and not the value one. I do not go near this column and click to edit the info so it's okay. So follow my advice at the beginning of this post.

select the file that's needing attention and right click on the file and open the extended dialog an if they display like that then I'm afraid your previews info is gone.

To get rid of 'ead's' Use:

For the %lead% use the replace with regular expression:
Field: LEAD
regexp: ^(?-i)ead.s$
replace with: leave this blank

I have gone thru every tagg in Customize Column and the only thing I found was some tags with expressions in value part ...like %_tag_read%[ (%_tag%)]. Is this considered to be a value part with two fields?? Even if they are not activated in the list?

If I remove these parts, will I get rid of the problem?? The solution you mentioning in beginning of posts

Enter %lead% and %variant% in the fields option of the column setup only and not the values.

dont work for me, I cant edit the cells by clicking them after changing to that. I need to be able to click the cells and edit the content.

Sorry for being troublesome!

THis column displays (! - as there is only a definition in the value) what kind of tags were found in a file and which content you see. I would not remove that column - but it would not hurt either.

If you want to be able to write a FIELD then you have to enter the name of the field.
It is only possible to write to one field at a time. So if you want to write to several fields you either ...
... have to create column defintions for each field separately
... or create actions that copy the contents of one field to another.

A definition for field like "%first% %second%" is invalid. It has to be one for "%first%" and another one for "%second%.

I would assume that the strange values you see come from an invaldi field definition.

Follow my earlier post Part of column name in tag

Set up a separate column with the appropriate values for the variant column. The use my regexp to get rid of unwanted values in those fields and then unfortunately tag them again.

I have checked every field and value, and none of them has double variables in either value or field.... if the example I gave not counts as doubles.

All my field definitions got %name_of_variable%,or is empty........?

Done!

Let see if this problem arise again.

Shall I remove the regexp after done?

No no. Once you have the fields setup like the link in my previous post. Use the action replace with regular expression action. Don't place that regexp in the column setup.

Press this :mt_act: and choose the replace with regular expression and use the examples I have giving you like.

For the %lead% use the replace with regular expression:
Field: LEAD
regexp: ^(?-i)ead.s$
replace with: leave this blank

Not? But it worked :slight_smile:

There is no LEAD (or any of my fields I have done) in the list of fields - is it because its a custom tag I´ve made??

Are you sure, it might only display that way of you still have the regexp in the value part of the column setup.

Exactly, because they are all unique to you.

So, in other words, I cant use action "replace by regexp" on them, or? :slight_smile:

Trying to do so I get no change!

Beginning to think there must be some sort of bug here.....or may I missed something in configuration?

Please try what I told you. I won't tell you if I didn't think it would work.

There's no bug, You cannot place more than two fields in the value part of the column set-up and still think you can edit the column and the fields remain correct. Maybe I didn't make myself clear but that's it.

Let see - this have I done so far:

Enter %lead% and %variant% in the fields option of the column setup only and not the values.

Check - is done, my answer:

If I do that all the data I have entered in columns is disapeared.
And I cant write in new data by doubleclicking cell...

Create a separate column for each:
One example:
Name: Lead
Field: %lead%
Value: %lead%

Check - is done, my answer:

:slight_smile: Thats exact what I did in the beginning :slight_smile:

But strangly some of the values is overwritten by part of the columnname.

To be clear - none of the column I made before error had double fields,
and I checked it after you told me, still single fields.

And I have tried to use your regexp with Action.
Since there was none of my tags in the selector (in Action-dialog) I wrote in the name on the field myself, but there was no change in cells after running action. (I copied regexp from your post). I tried to rename columnname to big letter (the selector forced me to use big letters) but no change, I have used the fieldname with % before and after the name...same result, none.

Now I have entered each cell and corrected the values by hand, so it look like before I got the error. Let see if the error show up again......:slight_smile:

Thanks for your help, as you can see I have done what you told me. And I have not
placed more than two fields in the value part of the column set-up, I have only one (1) field in the value part of column set-up. Sooooo....either we are totally misunderstanding each other....or....?

To be perfectly clear setup one column like so for LEAD:

And another for VARIANT:

Press the win+R key on your keyboard and paste: %appdata%\mp3tag\data\sources
press return and place this group action in there:
_Script_Test_TEST.mta (110 Bytes)

Then run that on the infected files. Hope this helps.



_Script_Test_TEST.mta (110 Bytes)