Phantom duplicate tracks


#1

Hi
(And sorry if this is posted elsewhere already, I have searched.)
I have a folder on my NAS which contains about 4000 mp3 files. I am finding that in the the MP3tag file listing, some of the files appear more than once, with the exact same filename but with old metadata. It is like it is reading some indexed information, not the actual files that are now present. Is this a setting somewhere I can change or what do I need to do to stop this happening? The files aren't really duplicated (obviously!) but appear on the list with the same file name. It's bizarre and makes trying to do meaningful comparisons with another copy of the same files impossible.
Cheers
Susan



#2

I don't think it's possible for mp3tag to read files that don't exist. Expand the file location column in your mp3tag window... right above where it says all the '\\NAS-88....' to see where the files are located.

Note: No two files cannot co-exist in the same folder with the same file extension.

If you find that there are dups which is highly likely then set the following up to open windows explorer and locate the bogey file.

  1. Ctrl + O or :mt_options: (brings you to the options)
  2. Go to Tools
  3. :mt_new:
  4. Name: Open Explorer Path: C:\Windows\explorer.exe Parameter: /e, /select, "%_path%"
  5. Okay
  6. (Optional) [x] Use special program at double clicks (This allows you to double click the file and open up windows explorer.
  7. Okay
Now to either double click the bogey file as above or right click over the file>Tools>Open Explorer. Then get rid of the file.

A quicker way is to expand the column see the file that does not belong and right click>delete...

I'd be amazed if you didn't have a duplicate file as I've never had a problem like this.


#3

Good grief what a lemon. I didn't realise it would read sub folders and list them as if they were in the same folder, I took it to mean that folder only. Ok - this is no longer a support request, it's a feature suggestion :wink: option to include sub folders or not!!

Thanks. :w00t:


#4

I hate to be the bearer of more bad news but that already exists.

  1. Click :mt_diradd:
  2. See :]