Playing FLAC files in correct order via Squeezebox

Hello there,

I am using mp3tag to tag FLAC files which I then want to play via my good old Squeezebox. I run the squeezebox server on my NAS. When the files are not tagged, Squeezebox takes the file name to define the order. But the fact is that I like to tag the files with artist/album/year/discnumber/track/title as a minimum
I mainly use the tagging for live concert bootlegs I am collecting.
Often these are multiple discs when they are coming from CD bootlegs. I use for filenames always "D%discnumber%T%Track% %title%" as the filename. track title is sometimes with or without a discnumber. So e.g 01,02,03 or 101,102. Discnumber I always use a plain 1,2 etc. In this setup the order is always selected correctly, assuming bases on disc and track number

But in case of single discs or a full concert audio without disc separations my squeezebox does not pick up the right order it seems and sorts the files alphabetically on track title.

a solution would be to keep the track number in the title, but I don't like that to be honest.
But I mainly want to understand why this happens. Why does Squeezebox not order on track number when having a single disc album, but does do it correctly as soons as mutiple discs are in the album...

I assume that you have the same fields set in a single disc album.
I am missing ALBUMARTIST in your list of fields

So perhaps adding ALBUMARTIST would help.

Sorry, yes I always fill the album artist field.
i must correct myself as I found also that in some (not sure all) multiple cd sets, the order was also alphabetically (per disc) .

Ok I did some further testing.

  • When I tag all fields except for "track" my player plays them in the correct order, probably because it looks at the file name

  • BUT if I tag also the track number, then the player switches to alphabetically and something goes wrong.
    So my workaround could be to tag all except for the track no. but if someone has an idea what can be cause and solution, I would be happy to hear

This isn't really an Mp3tag question, although it could have something to do with how you're using Mp3tag. Have you posted the question in the Squeezebox forums? You'll get a lot more help over there.

Is this happening for all albums, or only some of them? Offhand, this sounds pretty much like how I tag files. One thing that I do, however, is that I never use DISCNUMBER and TOTALDISCS tags on single disc albums. The main reason is that when using something like


as a title display format in LMS, I don't want to see the disc number with all the single disc albums that make up 99% of my library.

One thing I always tell people who are good about tagging all of their files, is to completely disable the "guess tags" feature of LMS, so that it never uses information in the file name. To do that, you'd clear all of strings that appear under

Settings > Advanced > Formatting > Guess Tags Formats

If, however, you don't tag all of your files and you want it to use file names, you'll want to keep that and possibly modify it according to your file naming convention.

You could post all of the tags from, say, two tracks on one of your albums that isn't sorting correctly. Post the text that you see in the LMS web interface when you drill down to the track level and click 'View tags'.

Thanks for the response.

I followed your advice to remove the guess tags. Is there also an option to select file name as playing order?

here example of 2 files that are not played in the right order:

ALBUM: 1980-10-25 The Mountain Show - Memorial Coliseum, Portland, OR (Ev2)

ALBUMARTIST: Bruce Springsteen and the E Street Band

ARTIST: Bruce Springsteen and the E Street Band

COMMENT: Taper : Pat Lee



TITLE: Badlands


VENDOR: reference libFLAC 1.1.2 20050205

YEAR: 1980

ALBUM: 1980-10-25 The Mountain Show - Memorial Coliseum, Portland, OR (Ev2)

ALBUMARTIST: Bruce Springsteen and the E Street Band

ARTIST: Bruce Springsteen and the E Street Band

COMMENT: Taper : Pat Lee



TITLE: Darkness On The Edge Of Town


VENDOR: reference libFLAC 1.1.2 20050205

YEAR: 1980

and what does the filename look like?

101 Prove It All Night.flac
104 Darkness On The Edge Of Town.flac
113 Badlands.flac

So the LMS plays the discs in right order , but the songs per disc in alphabetical. Many of these live recordings are numbered in 2 or 3 cd sets. But if it would be one cd set, the issue would be the same

So, the easiest way would be to add the complete track number to the TITLE.

Yes, that is true. But I wonder if there is no real solution or setting.

Your problem might be that these have the wrong field name for track number. The correct name should be TRACKNUMBER. I could be wrong about that, because LMS might recognize both names, but I'd change them all and see what happens.

In Mp3tag's options, go to Tags > Mapping and see what you have for User-defined field mappings. I believe the following are configured by default (it's been a long time since I installed Mp3tag, so I'm not positive):

Tag Source Target
VorbisComment DATE YEAR

What this means is that you always use the name TRACK in Mp3tag, but it will read and write TRACKNUMBER. What I would guess happened is that some other program incorrectly tagged the files with that name and Mp3tag has never rewritten them.

This could actually be difficult to fix in Mp3tag, since that mapping will mean it would always read/write TRACKNUMBER when you try to address the TRACK field. You could remove the mapping, copy those numbers to a different field, restore the mapping and rewrite them to the correct field name, but there's probably an easier way.

Wow, Yes I think I found it due to your suggestion.
In my installation there were no mappings. So I added them for Date->Year and TRACK->TRACKNUMBER. I will test after some re-tagging work.
I also found and album that was tagged longer time ago and plays in the right order. Here LMS showed TRACKNUMBER in the tags and not TRACK"

I still need to test it more, but it looks like you helped me finding the rootcause of my issue.

I also found the same issue on the LMS forums: