Possible bug in Convert Tag -> Tag not taking place?

I've been using mp3tag for several years as a casual user, and I think I understand how it is supposed to work. Suddenly though, my tag to tag conversions are not working. Especially with regards to changing the TITLE of a track.

I've documented as best I can at this imgur album:

http://imgur.com/a/keVUR

It shows how I have 4 tracks whose title I would like to change. I'd like to prepend each existing title with "Jekyll & Hyde".

I ask for a preview, and it seems to work (although there it oddly seems to say the existing title already has "Jekyll & Hyde" prepended to it.

I then let it run, and you can see that:

  1. The title seems to remain the same.
  2. The file modified time has not changed.

The rest of the album are my mp4tag tags settings, which I have never touched, so they should be the default.

I am running v2.70, but I saw this behavior earlier today on v2.69, so I exited and upgraded.

Regarding the preview, I tried this several times, so as unlikely as it seems, is there possibly an internal field of title somewhere that did get changed?

I am not sure if this is a bug, or my own misunderstanding of how things work, any help would be appreciated.

You can attach your screenshots directly to your post ...




















Please show us an additional screen shot of the Mp3tag listview having columns defined as ...

Name: TagRead (TagTypes)
Value: %_tag_read%[' ('%_tag%')']

Name: File Mod DT
Value: %_file_mod_datetime%
Sorted by: %_file_mod_datetime_raw%

Name: Title
Value: %TITLE%

There should be no problems ...



DD.20150516.0739.CEST



Thanks for taking a look at this.

Here is the screenshot with the new columns added.

http://i.imgur.com/qdtYHyH.png

Thank you for your help and fast response.
Unfortunately, there is nothing special to discover regarding the involved tagtypes.
You can remove the extra columns.
Is it somehow feasable for you to repeat step 1 and 2 from my test proposal from post#3?
Have a closer look to the name of the target tag-field!

DD.20150516.1120.CEST

Ah! I solved it, I was being dumb (again).

Somehow in the field "field:" I had placed %TITLE% when it should only have been TITLE. And in fact you did it right in your example, I missed that.

But this morning, I looked closely again, and saw it.

So fixed, and thank you for the swift help.

mp3tag is a fun, handy little tool.