Preserve special characters during action group

I have a properly tagged mp3 file in which some tags have proper unicode characters. When I perform an action group to spit my band member field into separate fields for each band member contained in the original band member tag, the unicode characters are not preserved and are replaced with unreadable garbage.

Replace "BAND": "\\" -> "\\"
Split fields by separator "BAND": "\\"

How may I avoid this behavior? Note that I do not see this behavior with flac files. Also some special characters are preserved - like é but not ā.

Check that you are set to write UTF-16 for ID3v2 tags.

Tools -> Options -> Tags -> Mpeg -> Set ID3v2.3 UTF-16

BAND='abc+++Звезды+++Çay Elinden Öteye+++Drei 1⁄2' BAND=$replace(%BAND%,'+++','\\\\') ... or ... Split fields by separator: Field=BAND Separator=+ ... both works for me ... using "ID3v2.4 UTF-8" ...

... there are four tag-fields BAND now with proper content.

DD.20140113.1047.CET

Did the trick for me. Thanks!