Problem bei Export -> RTF


#1

Hallo Gemeinde,
seit dem Umstieg von 2.31 auf Version 2.34e klappt der Export nach RTF nicht mehr!
Bei Einstellung mit UTF-8 mit BOM werden die RTF-Steuerzeichen mit ausgegeben.
Beispiel:

{\rtf1\ansi\ansicpg1252\cols3\colsx600\margr900\margl1800\margt500\margb500\deff0\deflang1033{\fonttbl{\f0\fswiss\fprq2\fcharset0 Arial;}}

\viewkind4\uc1\pard\b\ulth\f0\fs35 MP3-25 \ul0\par

\fi-230
\par\b\fs16 01 Alexander - Take Your Cchance\b0\fs12\par
01 - Take Me Tonight\par
02 - I Dont Wanna Say That\par
03 - From The Heart Of An Angel\par

  • schnipp -

Ohne BOM kommen die Umlaute nicht richtig.
Beispiel:

  • schnipp -
    07 - Nur für Mich
  • schnipp -

Hier meine "RTF-Liste 3-spaltig A4.mte" :

$filename(rtf){\rtf1\ansi\ansicpg1252\cols3\colsx600\margr900\margl1800\margt500\margb500\deff0\deflang1033{\fonttbl{\f0\fswiss\fprq2\fcharset0 Arial;}}

\viewkind4\uc1\pard\b\ulth\f0\fs35 MP3-%_workingdir% \ul0\par

\fi-230
$loop(%_folderpath%)\par\b\fs16 %_directory%\b0\fs12\par
$loop(%_filename_ext%)%_filename%\par
$loopend()
$loopend()

}

Was läuft da schief?

Ich wünsche Allen ein frohes Fest und einen guten Rutsch!
Rudi


#2

Hmm... Stimmt - scheint auch mit dem RTF Export von Florian schief zu laufen. :frowning:


#3

Hallo Rudi!

RTF kann anscheinend kein UTF-8 :frowning:

Hier ein Work-Around:

  • Ohne UTF-8 BOM exportieren
  • Datei in Notepad öffnen und
  • bei Speichern unter... > Codierung ANSI auswählen
Viele Grüße, ~ Florian

#4

Hallo Florian,
Dank erstmal für die schnelle Hilfe.
Es funktioniert, aber bei "Massenabfertigung" nicht akzeptabel.
Werde wohl bis zum Fix bei 2.31 bleiben :frowning:
Ist Abhilfe in Sicht?
Gruß Rudi


#5

Hallo Rudi,

der aktuelle Development Build kann Dein Problem lösen :slight_smile:

Dazu öffnest Du einfach die Exportkonfiguration und schreibst in die erste Zeile einfach $filename(mp3tag.rtf,ansi) Damit wird die Exportdatei in der System-Codepage wie in den alten Versionen geschrieben.

Viele Grüße,
~ Florian